Jump to content

Cache become Unmountable after reboot (SOLVED)

Go to solution Solved by JorgeB,

Recommended Posts

Maybe not relate, but that's my first reboot after updated to version 6.12.2, as my Unraid system been up for almost three months.


The error message on the Array is: 'Unmountable: Unsupported or no file system'

The error message I got is:


Jul  2 13:46:33 Tower emhttpd: read SMART /dev/nvme1n1
Jul  2 13:46:43 Tower emhttpd: Seagate_FireCuda_520_SSD_ZP1000GM30002_7QG01AHT (nvme1n1) 512 1953525168
Jul  2 13:46:44 Tower emhttpd: import 30 cache device: (nvme1n1) Seagate_FireCuda_520_SSD_ZP1000GM30002_7QG01AHT
Jul  2 13:46:44 Tower emhttpd: read SMART /dev/nvme1n1
Jul  2 13:53:15 Tower emhttpd: /mnt/cache: no btrfs or device /dev/nvme1n1p1 is not single


No sure what's error message is about as the device seem passed btrfsck with no issue.


And following this FAQ:

I can at least mount it as read-only, didn't try anything further yet, as I don't understand why Unraid cannot just mount the Cache drive as it seems the data is here and the drive is physically fine?


Think I am going to manually copy the data and maybe try to restore the data using:


btrfs restore -v


Cache files system check is fine:

WARNING: filesystem mounted, continuing because of --force
[1/7] checking root items
[2/7] checking extents
[3/7] checking free space tree
[4/7] checking fs roots
[5/7] checking only csums items (without verifying data)
[6/7] checking root refs
[7/7] checking quota groups skipped (not enabled on this FS)
Opening filesystem to check...
Checking filesystem on /dev/nvme1n1p1
UUID: 66969f3d-4d56-4866-bbb0-b26a91821903
found 648195293184 bytes used, no error found
total csum bytes: 6924772
total tree bytes: 230391808
total fs tree bytes: 109608960
total extent tree bytes: 110395392
btree space waste bytes: 25295333
file data blocks allocated: 648014184448
 referenced 647944634368


Edited by pliu
mark as solved
Link to comment

After bit of random changes and got my system back to operation.


After play around the cache pool setting I realized that the error might be to do with btrfs by default using RAID for 2 ssd drives, and I removed one to un-assigend a couple of years ago.


Somehow the new version of Unraid decided that my cache should still be mirrored so complains that it is not single as  I only assigned one ssd to cache pool.


I then confirmed the unassigned ssd still have the cache content exactly same as the cache ssd. However after add the un-assigned ssd back the cache pool, I got more errors. I think it might be to do with the order of two ssds in cache pool are not same as I physically moved ssd around before ( I think). But Unraid does not allow me to move the ssds in the cache pool around, complains about missing drives if I just move ssd order around. I then end up remove all ssds from the current cache pool and add another cache pool, and now I have all the cache pool back!


Think that's probably enough for the day :D

Link to comment
  • Solution
5 hours ago, pliu said:

Somehow the new version of Unraid decided that my cache should still be mirrored so complains that it is not single as  I only assigned one ssd to cache pool.

Would need the diags to confirm but previous release didn't check this, now it does, so it won't allow to use one device in the pool whit the other device unassigned.

Link to comment
  • pliu changed the title to Cache become Unmountable after reboot (SOLVED)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...