Wrong static IP configured (ifconfig vs GUI)


Go to solution Solved by itimpi,

Recommended Posts

Hi all -
This is really puzzling me.  My freshly installed server's actual static IP differs from what is configured in the GUI under Settings/Network Settings for interface eth0. 
After installing, I could not reach the server, so I logged in as root on the local console. Here I saw (issue) that the server was actually running .13 while I had configured .15 in the GUI. You will see the same thing in the diagnostic data attached: The static IP in system/ifconfig.txt differs from the one in config/network.cfg. So obviously, the server is only reachable under .13 for now, despite what is configured in the GUI.

 

How can this even happen? I assumed the GUI network settings will overwrite whatever is configured in Linux underneath? And more importantly: How can I fix this without breaking any of the generated settings?

shuttle-diagnostics-20231208-0636.zip

Link to comment
  • Solution
4 minutes ago, JorgeB said:

This is very strange, probably not the issue, but since I've never seen that before try setting the NIC to .15, not .015 as it is.

The 015 would explain it as the leading 0 means it is treated as octal number and 015 in octal is 13 in decimal

 

  • Like 1
  • Thanks 1
Link to comment
4 hours ago, itimpi said:

The 015 would explain it as the leading 0 means it is treated as octal number and 015 in octal is 13 in decimal

 

That's it, THAT'S IT. Removing the leading zero brings all back to normal. Just by some old habit, I've been using a leading 0 as a lot of broken UIs require you to enter 3 digits, so I don't even think about anymore. You have some serious troubleshooting moves going on there!

  • Like 1
Link to comment
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.