Windows Server 2019 VM - storage driver issue

Recommended Posts

I'm very new to unRAID/Linux, so I apologize for my ignorance. My day job is Windows environments, and I don't have a lot of personal experience with linux.


I'm sure there's something very basic I'm overlooking, but I've been trying for hours to get a 2019 Windows Server VM to run. I finally have the VM starting, am at the disk selection, but am having the classic no storage devices issue due to drivers.


The 30GB vdisk is connect as a SCSI device, and both the Windows iso and viritio 1.240-1 are connected as SATA. Machine is set to Q35-7.2 and BIOS is set to OVMF. HyperV I left on yes, USB left on 2.0 but I'm not using USB, or any PCI-e devices. Just a bare bones Windows VM so I can test my applications. I also used the WinServer 2016 template.


I've tried both drivers under vioscsi and viostor, which also show up as "unsupported" and don't work anyway when tested.


If it matters, this is currently running on a HPE DL360p Gen8 server, with HP SAS disks setup as just individual RAID0 disks, and then the array is built in unRAID as anyone else would. This will be different in my final system, this is just my test system, but I'd expect it to work all the same.


At a loss here and have no idea where to go next. Tried searching the forms/google, which is what helped me get to where I am, but can't seem to get past this.

Edited by soulvoid86
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.