Jump to content

Unraid broke...swapped cases, now drive disabled and gives udma error...


Go to solution Solved by JorgeB,

Recommended Posts

Hello all, I recently swapped my Unraid server to a new case. All the same hardware as before except the motherboard:

 

Phantom B550 itx

5950x

64gb ram

3060 12gb

Array - x1 16tb HDD, x2 8tb HDD, x1 2tb HDD

Cache - 500GB WD 2.5 sata ssd

Baremetal - 2tb nvme ssd, 2tb HDD

SFX corsair 750 psu

Orico nvme to x6 sata card

 

Everything was working fine before I did the switch. It took me awhile to figure out how to get the IMMOU groups to work on the new board with some bios settings and Unraid. After I figure that out, I was getting some weird boot problems and still am but everything seems to work fine except the one drive. Errors and solutions to the boot problems:

 

-Array would boot but VMS, Docker would load blank screens. Fix was to redirect to location on cache drive for Docker, had to recreate VM image.

 

-When the array would boot the file system would say invalid and have not files. Above fix seem to solve this as well.

 

 

Need help with:

 

-Now for one of my disk it says invalid disk and is emulated, the error is udma error. Did a little research and everything I saw said it was a physical connection problem. I tried several different cables and also changed from different SATA ports on the Orico hba and also switched to a sata on the motherboard and this still didn't solve the issue.

 

-Also when Unraid is booting it will freeze on "NET: Registered PF_UNIX/PF_LOCAL ". Everything still boots up but is stuck there on the screen.

 

I have attached a diagnostics file, thank you in advanced so much!

 

nas-diagnostics-20240122-0624.zip

Link to comment
1 hour ago, JorgeB said:

Diags show what look like power/connection issues with disk1, replace cables and post new diags after array start.

 

So I've tired multiple different cables and sata ports. I've even swapped disk1 to disk2 and the same drive is giving me the same errors.

 

I can do this again and leave them swapped. Then generate a new diags after, later this evening if that might help.

Link to comment
10 minutes ago, trurl said:

Including power cables? Splitters involved?

The Jonsbo N3 has a backplane that has x2 Molex power plugs and x1 Sata power plug going to it. I have all three plugged in. Here is a picture of it: (photo is not mine) N3 Backplane

 

Do I need to replace the power plugs from the powersupply to the backplane?

Link to comment
2 hours ago, trurl said:

You should at least reseat the connections.

 

4 hours ago, JorgeB said:

Diags show what look like power/connection issues with disk1, replace cables and post new diags after array start.

 

Here is the latest diag

 

What I did this time was bypass the backplane and plug each drive in separately all with new cables. The same drive is coming up disabled and it is plugged into the same port the parity was previously.

 

Could there possibly be something wrong with my config somewhere causing this?

 

Could the ACS override be causing this?

 

All just doesn't make any sense since everything was working fine in the other case / motherboard (B550 creator) 

nas-diagnostics-20240122-1208.zip

Link to comment
22 minutes ago, JorgeB said:

This is expected, once a disk gets disabled it needs to be rebuilt.

 

I no longer see ATA errors for disk1, emulated disk2 is mounting and the disk looks healthy, if contents look correct you can rebuild on top:

 

https://docs.unraid.net/unraid-os/manual/storage-management#rebuilding-a-drive-onto-itself

 

Oh nice : ), I just started the rebuild, fingers crossed.

 

The other error I am getting is the screen is frozen on this screen, (attached photo) Everything seems to work fine on Unraid though.

 

PXL_20240122_174351052_MP.thumb.jpg.0ef9a0eb468c16ad40b59d12faaeebf7.jpg

Link to comment
16 minutes ago, JorgeB said:

Not sure what that could be, don't see any other GPU installed, if there were multiple it could be outputting the current screen via another one.

Ahh, I bet that is it. I'll try to swap to the HDMI port instead of the DP port on the GPU.

 

Thank you so much for everything

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...