Jump to content
We're Hiring! Full Stack Developer ×

Nach Update von Unraid verschwindet meine Cache SSD


Go to solution Solved by alturismo,

Recommended Posts

Hallo,

ich hab mal wieder nen Update von unraid gemacht von 6.11.5 war das glaub ich auf 6.12.6.

 

Lief nachdem update auch alles, nach paar stunden aber sind meine Docker nicht mehr da, Teils zwar angeblich noch an aber nicht mehr erreichbar, andere dafür gestoppt und lassen sich auch nicht starten.. und meine USB HDD ist Aktiv (normal immer am schlafen weil ich da selten drauf zugreife da alles auf dem Cache liegt was ich Täglich nutze)

Nach einem Neustart dann der Schock "Cache SSD nicht mehr gefunden"

Einmal ausschalten und wieder einschalten und die SSD ist wieder da und alles läuft 1a

 

Wenn ich dann ein Downgrade mach auf die 6.11.5 hab ich das Problem nicht aber mein "App Store" geht nicht mehr

 

Im Anhang mal der Syslog vor dem ersten Neustart

 

Jemand ne idee evtl

 

Kurz zum System:

Alter Intel Nuc "D54250WYK" Cache SSD intern

USB HDD 3,5Zoll die bei der Alten version auch sauber Schlafen ging usw

syslog.txt

Link to comment
30 minutes ago, Cupra-Bo said:

Jemand ne idee evtl

 

Quote

Jan 22 16:27:30 Nuc kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 16, rd 12, flush 1, corrupt 0, gen 0
Jan 22 16:27:30 Nuc kernel: I/O error, dev loop2, sector 13592656 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 2
Jan 22 16:27:30 Nuc kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 16, rd 13, flush 1, corrupt 0, gen 0
Jan 22 16:27:30 Nuc kernel: I/O error, dev loop2, sector 13592656 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 2
Jan 22 16:27:30 Nuc kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 16, rd 14, flush 1, corrupt 0, gen 0
Jan 22 16:27:30 Nuc kernel: I/O error, dev loop2, sector 13592656 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 2
Jan 22 16:27:30 Nuc kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 16, rd 15, flush 1, corrupt 0, gen 0
Jan 22 16:27:34 Nuc kernel: I/O error, dev loop2, sector 13592656 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 2
Jan 22 16:27:34 Nuc kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 16, rd 16, flush 1, corrupt 0, gen 0
Jan 22 16:27:34 Nuc kernel: I/O error, dev loop2, sector 13592656 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 2
Jan 22 16:27:34 Nuc kernel: BTRFS error (device loop2: state EA): bdev /dev/loop2 errs: wr 16, rd 17, flush 1, corrupt 0, gen 0

 

BTRFS Fehler. Hast Du einen Single Device BTRFS Pool oder besteht der Pool aus mehr als einer Platte? BTRFS Pools bestehend aus mehr als einer Platte reagieren z.B. nach einem Stromausfall allergisch.

 

Edited by hawihoney
Link to comment
1 minute ago, hawihoney said:

 

BTRFS Fehler. Hast Du einen Single Device BTRFS Pool oder besteht der Pool aus mehr als einer Platte? BTRFS Pools bestehend aus mehr als einer Platte reagieren z.B. nach einem Stromausfall allergisch.

 

Ich hab nur eine Cache SSD und eine Normale HDD an dem System

 

Stromausfall gab es nicht wäre auch nicht so schlimm weil USV davor

 

ob das jetzt ein BTRFS pool ist kann ich dir gar nicht sagen so tief bin ich da nicht drin sorry

Link to comment
17 minutes ago, hawihoney said:

 

Screenshot von der Hauptseite bitte.

 

BRTFS jetzt seh ich das :D

 

EDIT: ich hab das update vor paar tagen schon mal gemacht und hatte dann keine Zeit und hab ein Downgrade gemacht da lief die kiste dann wieder ohne Zicken 6-7 tage durch also möchte ich Hardware Defekt ausschließen

 

Start.PNG

Edited by Cupra-Bo
Link to comment
14 minutes ago, Cupra-Bo said:

BRTFS jetzt seh ich das :D

 

bei Gelegenheit alles wegsichern, Platte in xfs formatieren, retour spielen, länger sorgenfrei ...

 

btrfs macht nur im pool mit mehreren Platten Sinn, single Drive nicht ... und da btrfs (meiner meinung nach) leider viel zu anfällig ist ...
kann ich nur empfehlen einen Bogen darum zu machen ...

Link to comment
13 minutes ago, Cupra-Bo said:

BRTFS jetzt seh ich das

 

Hattest Du neu gestartet? Die GUI zeigt keine Fehler. Ggfs. wurden bei einem Neustart die Fehler behoben (Stichwort Transaction Log).

 

Ansonsten kann ich nicht helfen. BTRFS ist bei mir ein rotes Tuch. Andere hingegen schwören drauf. Mir hatte BTRFS einmal alles zerschossen. Das war mir mit ReiserFS (früher) oder XFS (jetzt) noch nie passiert.

 

Solange nur eine Platte in Pools betrieben wird, würde ich persönlich XFS nehmen.

 

Link to comment
1 minute ago, alturismo said:

bei Gelegenheit alles wegsichern, Platte in xfs formatieren, retour spielen, länger sorgenfrei ...

 

btrfs macht nur im pool mit mehreren Platten Sinn, single Drive nicht ... und da btrfs (meiner meinung nach) leider viel zu anfällig ist ...
kann ich nur empfehlen einen Bogen darum zu machen ...

Puu da ist die Frage wenn ich jetzt alles sicher, wie bekomm ich sie dann in XFS und wie sieht es dann mit meinen Dockern usw aus wenn ich dann wieder alles genau so auf die SSD packe

Link to comment
1 minute ago, hawihoney said:

 

Hattest Du neu gestartet? Die GUI zeigt keine Fehler. Ggfs. wurden bei einem Neustart die Fehler behoben (Stichwort Transaction Log).

 

Ansonsten kann ich nicht helfen. BTRFS ist bei mir ein rotes Tuch. Andere hingegen schwören drauf. Mir hatte BTRFS einmal alles zerschossen. Das war mir mit ReiserFS (früher) oder XFS (jetzt) noch nie passiert.

 

Solange nur eine Platte in Pools betrieben wird, würde ich persönlich XFS nehmen.

 

 

Nachdem Neustart wurde das Array nicht gestartet da eben die Cache SSD nicht gefunden wurde .. erst nachdem ich die Kiste komplett Runtergefahren hab und dann wieder gestartet hab ging alles wie gewohnt

 

Komisch ist halt das es erst seit dem Update ist

Link to comment
10 minutes ago, Cupra-Bo said:

Puu da ist die Frage wenn ich jetzt alles sicher, wie bekomm ich sie dann in XFS und wie sieht es dann mit meinen Dockern usw aus wenn ich dann wieder alles genau so auf die SSD packe

 

1/ Docker, VM aus

2/ wenn Docker == Docker directory, löschen, wenn Image ist es egal ...

3/ Alles Shares umstellen auf cache > array

4/ mover starten und warten bis alles drüben ist

5/ Cache platte rausnehmen (new config)

6/ Platte in UAD formatieren in xfs

7/ new config, Platten zuweisen

8/ Shares umstellen wie vorher (bzw. wenn vorher cache only auf array > cache)

9/ mover starten das wieder retour gespielt wird

10/ fertig, docker / vm Dienst starten

11/ wenn Docker Directory war, Docker aus user templates wieder installieren, Settings kommen vom USB Stick, persistent Data liegen ja in /appdata und sind nach dem move wieder da wo Sie sein sollen ...

 

Dauer, je nachdem was an Daten hin / hergeschoben werden muss ...

image.thumb.png.77a03afd33097ae659f6de0e14def13e.png

 

ansonsten, Array == USB HDD ... bin ich raus ;)

  • Like 1
  • Upvote 1
Link to comment
1 minute ago, Cupra-Bo said:

Komisch ist halt das es erst seit dem Update ist

 

Das ist unerheblich. Hat garantiert nix damit zu tun. Lesefehler von Sektoren sind eindeutig Dateisystem- oder Hardware Probleme.

 

Zum Backup/Verschieben: Da gibt es alleine innerhalb der letzten 7 Tage diverse Posts im deutschen Forum. Stichwort: Mover.

 

Link to comment
24 minutes ago, Cupra-Bo said:

Irgendwo ist da noch der Wurm .. hab jetzt alles auf Array gestellt

 

zeig mal ein Beispiel ... und bitte vorab bedenken, es muss primary, secondary ... eingestellt sein ...

 

sonst macht der mover nichts falls du alles einfach nur primary array und fertig eingestellt hast ...

Link to comment
12 minutes ago, alturismo said:

zeig mal ein Beispiel ... und bitte vorab bedenken, es muss primary, secondary ... eingestellt sein ...

 

sonst macht der mover nichts falls du alles einfach nur primary array und fertig eingestellt hast ...

 

Ich kann bei Secondary schon gar nichts wählen es steht array drin aber kanns nicht anklicken

isos.PNG

Link to comment
1 hour ago, Cupra-Bo said:

Ich kann bei Secondary schon gar nichts wählen es steht array drin aber kanns nicht anklicken

 

war auch falsch erklärt meinerseits, sorry, natürlich

 

primary - cache

secondary - array

mover action - cache > array um alles auf das array z umoven

...

wenn alles erledigt ist

...

bei den Shares wo auf den cache sollen erst wieder umstellen auf

mover action - array > cache

 

dann am Ende überlegen welche Shares immer auf dem cache bleiben sollen, beispielsweise /system ... da secondary entfernen.

Link to comment
  • Solution
4 minutes ago, Cupra-Bo said:

Muss ich die platte ausbauen ? hab im moment keine möglichkeit die in nen anderes System zu bauen .. oder kann ich die irgendwie in unraid umformatieren

Nein ;)

 

Tools, new config ...

 

dabei setzt du den cache und das array retour (keine Angst, kein Datenverlust ...)

 

dann startest du das array NUR mit der einen 4tb als array disk und OHNE cache disk

 

dann installierst du (falls noch nicht vorhanden) unassigned devices plugin und unassigned devices plus plugin (zum formatieren)

 

Hilfe wie das geht findest du im unassigned devices plugin thread

 

wenn die disk formatiert ist, nochmals array stop, dann die cache disk wieder zuweisen, dann weiter mit Punkt 7 ;)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...