Jump to content

Server going haywire after cleaning

Go to solution Solved by JorgeB,

Recommended Posts

Hey guys.


I am a beginner in the sense of understanding when something goes wrong with the array but I've been trying to troubleshoot all day.


The thing is I wanted to add another drive to my array. All my drives are 4TB, 6 in total where 1 is parity. I wanted to transition to 8TB drives so the plan was to move the parity over to the 8TB new disk and move the old one to the pool. So I turned off the server, dusted cleaned it, put in the new drive and booted up.


That's where everything went to hell. Two of my drives acted up, one was missing and drive emulated (red X) and one was "Unmountable: Unsupported or no file system" but the icon was green. I had similar issues with the missing disk in October 2022 but I solved it by doing xfs_repair and it had no issues after that for all this time. I was so annoyed I went and bought another 8TB disk today to replace it, but that's when the strange things started. My server said both my new 8TB drives had errors on them, but they were new and not even formatted yet, so I formatted them and tried repairing but nothing worked.


It's worth mentioning I only have 6 SATA ports on my motherboard so I bought this 6 port SATA controller (Similar to this one: JMicron JMB585 https://cdn.nfp.is/kisildalur/20240213_151103_SYA0017569.jpg.). Could that have fucked up everything?


I recently changed all the SATA cables so I doubt that's the case. I've also tried xfs_repair without prevail.


Can anyone here tell my where I went wrong and if there is a possibility to at least get one drive stable to parity one of the disks because I only have one parity disk.


Here are 2 diags, one yesterday when all this happened and one today after all my tinkering where I hope I didn't break anything.


Thank you all so much for your help.


cybertron-diagnostics-20240405-2202.zip cybertron-diagnostics-20240406-2136.zip

Link to comment

I swapped slots on the motherboard and that seemed to have fixed this. I at least have the disks back without errors after parity check.


Could you explain why this could have happened? Is my motherboard not good for this? Should I use a HBA board?


This makes me scared to touch anything on the server if it's so fragile haha.


But thank you so much like always @JorgeB!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...