Jump to content

File empty after copy and paste

Go to solution Solved by fabo123,

Recommended Posts

Posted (edited)

Hi everyone


I have a Linux Mint client i work with.

Now to the problem I can create files on UNRAID in all shares, edit existing files and also delete them. But when I copy and paste a file, the file explorer hangs (NEMO). I tried a different Linux distro (also different file explorer) in a VMWare (VM on client Computer not Unraid) as a test - the same problem. With Windows computer (also as VM on same client as linux tests) everything works without problems. Btw, I'm talking about individual files with a few kb or even b not large or tons of files.
Locally it's possibel to copy and paste files, so I thought it might be because of the way I connected the share. All shares are connected like this:
// /home/test/Daten cifs username=test,password=*********,uid=test,vers=3.0
As soon as I have tried to copy a file on the share, the process remains active in the background and the whole file explorer becomes extremely slow (even locally) I have no chance to stall the process in any way - only a restart of the client helps.
I could not see any special in UNRAID log files and all disks are healthy.

At the moment I don't even know if the problem is Linux or UNRAID. I hope someone can give me a tip.


My system in short:

I use UNRAID 6.12.10. Have one pool for docker, one VM and cachdrive (2xssd) one pool sigle disk 8tb for VM. The array has 7 disk +parity.

American Megatrends Inc., Version 4204
BIOS dated: Monday, 14-08-2023


AMD Ryzen 5 PRO 5650G with Radeon Graphics @ 3900 MHz

Memory: 64 GiB DDR4 Multi-bit ECC



Edited by fabo123
Link to comment
Posted (edited)

This problem often occurs if you copy from a      User Share    to a     Disk Share    or vice versa.  (If the file in the User Share on the same 'Disk' where you are trying to copy the file to the using the Disk Share, you will be reading and writing to the same file simultaneous.)


If you install and use the   Dynamix File Manager     plugin, it will prevent doing prevent you from doing this.

Edited by Frank1940
attempt to clarify...
Link to comment

Hi Thanks for the reply. The file manager you mention is only internally on UNRAID. My problem is Linux clients (Windows works) which access the shars. If I copy a file in the same location, test.txt becomes test(2).txt which is then empty (even if I copy it to another folder or share it remains empty but with the same name). Unfortunately the file manager doesn't help me. 


Link to comment
  • Solution

Hi all

Just for information:

I tested a little again today. With my main (Linux Mint) and a VM MX-Linux. With X-Linux I got the message of updates today (I installed it fresh yesterday and didn't do any updates). After I ran the updates, the copying in the shares went again. So the fault here lies with Linux.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...