Jump to content
Sign in to follow this  
ednigma

Can't communicate with UnRaid

3 posts in this topic Last Reply

Recommended Posts

Turned on my UnRaid and after waiting a few minutes, tried to open the browser status and got a page not found (this seems to happen quite often), so I tried to telnet it and that also failed.  Had no choice but to hard reset.  After the reset, I was able to bring up the browser and saw that a parity check was in progress.  Refreshed the screen once and saw an est 270 min to finish.  After a few minutes, the screen changed and saw that my last disk was disabled and that the last two disks had some errors.  I clicked the button to stop the array (which had toggled to start -- I hadn't realized that the array was already stopped).  The array started but said that all my drives (7) except the parity drive, were unformatted and asked if I wanted to format the drives.  I clicked the stop button and it seemed to stop two drives and hang.  I telnetted in and tailed the syslog and saw some messages about read errors, but then the telnet window hung.  So I cycled the power and now I can't get the browser to connect and I can't get the telnet window to connect either.   Tried cycling the power a couple of more times (letting the system sit for about 15mins and seeing no disk activity before cycling the power).   My router's DHCP shows each time that it grants a lease to tower and I can ping the IP address, but I can't telnet or use the browser to connect.

 

What do I do now?  Do I need to hook up a keyboard and monitor and do some linux incantations?  I'm at version 1.050930.  My unRaid is usually off as I use it mainly to archive large HD transport streams.  The disk that is disabled is fairly new and has run thru the manufacturers advanced diags before initial installation

 

Thanks for your help

Ed

Share this post


Link to post

Tom,

 

I emailed you earlier today, not sure if you rec'ved it.

 

Did some more experiments today.  I hooked up a keyboard and monitor to see what was going on.  During post, I noticed that sometimes, my promise card would not see the last 3 drives connected to it.  I swapped it with a spare and rebooted and verified that all 4 drives were detected.  My system has 1 parity and 7 data drives.

 

When the scrolling messages stop, I see the following commands:

mount /dev/md1

mount /dev/md2

mount /dev/md3

mount /dev/md4

mount /dev/md5

mount /dev/md6

mount /dev/md7

remount /dev/md3

remount /dev/md1

remount /dev/md2

remount /dev/md4  and after a pause, I see the following:

 

fopen: No such file or directory

emhttp: no flash disk

shell_cmd: /usr/sbin/nmbd D

shell_cmd: /usr/sbin/smbd -D

 

When I try to open the browser, it seems to try to open the main page, but in the upper left corner, it says  "Invalid content..."

 

I can telnet in and top shows 100% Idle.

 

When I tail the syslog, I get

 

Sep  7 00:37:38 Tower kernel: end_request: I/O error, dev 21:41 (hdf), sector 488112128

Sep  7 00:37:38 Tower kernel: md5: read error!

Sep  7 00:37:38 Tower kernel: end_read_request 488112128/5, count: 5, uptodate 0.

Sep  7 00:37:38 Tower kernel: end_request: I/O error, dev 21:41 (hdf), sector 488374272

Sep  7 00:37:38 Tower kernel: md5: read error!

Sep  7 00:37:38 Tower kernel: end_read_request 488374272/5, count: 5, uptodate 0.

Sep  7 00:53:23 Tower kernel: hde: lost interrupt

 

 

When I try to do an ls on each disks,  disk1 thru 4 are ok, but disks 5,6,7 don't show any directories or files.

 

I thought I read somewhere on these forums that some config data such as disabled disks is written to the flash drive.  If my previous Promise card intermittently detected disks 5,6, and 7, could this have hosed up something in the flash.

 

Assuming that I haven't corrupted andy data on the data disks (my first hang was during a parity sync) what's the best way to fix this?

I guess that if I can somehow get back to the main browser window and all my data disks show up I can reset the array to regen the parity disk.

 

Thanks

Ed

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this