Jump to content

Unable to delete files in only one folder in a share.


0bit

Recommended Posts

Hello Everyone

 

I've finally got YAMJ working on my unraid server and have run in to a problem that I'm not sure how to fix.  My share is setup as Movies with the following folders in it:  Bluray, DVD, YAMJ, and Jukebox.  I am able to edit, delete, and copy on to all the folders except the Jukebox folder when I log in as Admin (has read/write access).  When I tried to clear out some of the old xml, html, jpgs out of the Jukebox folder on my win7 machine, I get a popup window that I need the access rights of the account "root".  Would running the new permission script fix this? Or should I try the "chmod +x /mnt/user/Movies/Jukebox" command on the unraid server?  Any help is appreciated and thank you in advance.

 

My unraid version is 5.14 with ASUS P8Z68-V PRO with I3 2100 processor. 

Link to comment

I ran the ls -alg and got a bunch of text that I'm guessing it says the user root owns all of the files.

 

a chown -R nobody:users THE_DIRECTORY_HERE should fix it so that you can edit/change/etc the files from the windows machine again.

 

As for the "admin" user thing.  I was assuming you were moving files around in windows as the root user (i.e. logged in as root) which should have caused the same issues as you see from "mc"

I typed in "chown admin /mnt/user/Movies/Jukebox"  at the prompt and was able to delete the files from my Jukebox folder with the admin acct.  We'll see if it blows up tomorrow.
Link to comment
  • 2 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...