Jump to content

unRaid Wont Boot. No floppy controllers found ?

Recommended Posts



I have been running unRaid 5.x for about a year or so with no problems. Now every time I restart unRaid I get the following error and the boot process hangs:


floppy0: no floppy controllers found

VFS: Insert root floppy and press enter.


Once I get this error, I can't do anything. In the past if this popped up I could get past it by turning the PC on and off a bunch. Now I can't get past it. Can anyone point me in the right direction? I am a complete beginner with linux based systems and cannot for the life of me figure this out. I've tried searching for the error, but find little to no help. In the bios I have tried switching the USB drive to Auto, Floppy, Forced FDD, and Hard Disk all of which produce the same problem. I would really appreciate some direction here. Thanks. !

Link to comment

Look in your BIOS and DISABLE your floppy controller.


Then look at the boot order and be sure you've set your USB flash drive to the first item.    Note that on some systems the USB flash shows as a "hard drive" and you have to set the 1st boot device to hard drive; then go to a different menu for the "hard drive order" and set the USB flash as the first thing in that list.    On other implementations, the flash drive shows as a USB device, so you set the first boot device to that.


I suspect the reason your settings were lost is the CMOS battery is dead.    This is probably a CR2032 -- but double-check that on your motherboard [small round battery about the size of a nickel).    Very inexpensive ... just pick one of these up and replace it and once you get the settings correct you shouldn't have this issue anymore.


Link to comment

The motherboard does not have a floppy controller or a floppy header on the PCB. I double checked my boot order and the unRaid drive is set to option 1 in both spots. I also swapped out the bios battery for a new one and updated my bios to the latest version. Still nothing. Thanks for your suggestions though.


Here is a link to the screen shot. Thanks


Link to comment

I believe that sda is often  the 'device' name that Linux assigns to the Flash Drive.  (I really suspect that the 'no floppy disk controller' is more informational than true indication of a problem.) Try running chkdsk on your Flash Drive in a Windows computer and see if there is a problem with the drive.  (MAC's have a similar program for checking disks.) 

Link to comment

The full screen dump you provided in your later post made it very clear this was a Linux boot issue => nothing to do with the BIOS selection screen.  Your initial error description made it seem like the BIOS wasn't booting to the correct device => but the more complete screen showed that it was in fact booting to Linux, but LINUX was having problems.    That made it easy to determine that what was needed was to redo the flash drive  :)


Glad it's all working now.




Link to comment

Thanks everyone for the help. I just wound up reinstalling unRaid to my drive again. Booted right up and doing a parity check now. I didnt realize it was that easy else I would have done a full wipe first ha. Thanks again.


As soon as you get everything set up the way you want make a backup of the Flash Drive.  You will find instructions on how to do it here:




That way, you can be back up and running in about ten minutes by restoring your backup to the freshly formatted Flash Drive and running make_bootable again. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...