Jump to content
oconnellc

Help, my unraid files are 'Hidden'

6 posts in this topic Last Reply

Recommended Posts

I discovered that I cannot add music files that are on my unraid server to a media monkey library (they are FLAC and I want to transcode them to mp3).  So, I figured at least I should be able to copy them to my local XP machine and then add them to a media monkey library and then transcode them.  After copying them locally, I cannot do that, either.  So, I discovered while looking at the files in windows explorer that they are marked 'Hidden'.  This is the case for the files that are on the unraid server as well as the files that are copied locally.

 

This doesn't seem right to me.  I am accessing the files via a disk share, the permissions on the files are "777" and the share is exported "read/write".  Has anyone seen this before?  The worst part is that I cannot even change the files that I have copied locally!  When I look at the properties, the 'Hidden' checkbox is selected, but disabled, so that I cannot unselect it.

 

Any help on how to deal with this would be appreciated.  I'm pretty new to linux, so I thought that setting properties to "777" pretty much meant that anyone could do anything to the files.  I'm really confused on why windows is seeing them as 'Hidden'.

 

Thanks, Chris

Share this post


Link to post

I have never seen this, but I believe this happens occasionally to some users when the files were copied to the unRAID server in some unusual way.  The files are actually saved with both the System and Hidden flags, so you probably have to turn off the System flag first before you can turn off the Hidden flag.  I use Total Commander to change the attributes of groups of files, and I believe many other file managers can too.  I also use the free "Properties Plus!" Windows tool, which adds itself to the right-click context menu, and allows changing attributes and various dates for a file or group of files.

 

In Linux, you may also have to set the permissions on the containing directory too.  There is a little info here:  "How is a Linux console different from a Windows console?"

 

There are more knowledgeable users here, who can help and explain it better.

Share this post


Link to post

I never figured out why this is happening, but I did discover a tool called 'filo' that I was able to use to change the hidden attribute of the file.  Obviously someone crossed the streams when the files were getting copied, but flipping that switch made the difference.  If anyone has any idea why this might happen, I would love to hear from you.  File permissions just don't seem to translate 1==1 between windows and unraid...

Share this post


Link to post

I just ran across this problem.  I think you can easily reproduce it.  I installed rsync server from the slackware repository and set up a single share as read/write with root as the user and group.  On windows I am using deltacopy to sync the two folders.  Everything works fine except that any files created on unraid show up as system/hidden.  If you need any more details of config files, please let me know.

Share this post


Link to post

Thread necrofilia, I know, but I just ran into this and since it's the first hit on the search, I thought I'd add my 2 cents.

I ran into this after copying a load of files off a ntfs USB drive directly on the machine itself, so no samba was involved. I selected 'preserve Attributes' in midnight commander because I want to keep the original timestamps. I think this may have to do with it.

I solved this by going onto my windows box, mounting the share and open a command box (start > Run > cmd)

 

From there, I'd go to the share and run attrib recursively to remove all the unwanted attributes.

C:\>m:

 

M:\>attrib -S -H -R /S /D *.*

This way I removed all the System, Hidden and Readonly attributes from all files and directories on the share.

Share this post


Link to post

Here's a previous post that explains this: http://lime-technology.com/forum/index.php?topic=6374.msg61942#msg61942 (repeated here to generate warm-fuzzies)

 

It is not a bug. It depends on how you configured SAMBA to map additional non-unix attributes, like the WinOS HIDDEN flag.

 

Look into the SAMBA options of "map hidden", "map archive", and "map system" within the smb.conf man pages.

 

sam.0507.gif

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.