Drive Swap (dead drive in array)

Recommended Posts

I just had one of my data drives crap out on me and was hoping to get some advice on what to do next.


My current setup is 6 2TB drives and a 3TB Cache drive. One of the 2TB data drives died and I'm looking into getting 2 4TB to replace most of what I have. With a dead drive in the array will I be able to swap the existing parity drive for a 4TB without losing data from the dead drive? I really don't want to buy another 2TB drive if I'm looking to replace them with higher capacity drives. Not if I can help it anyway.


I've been out of the loop on the UnRaid scene for a while now and will need to brush up on my knowledge. In the meantime I would really appreciate whatever help/advice anybody can give. Thanks guys!


edit: Sorry I guess it's worth mentioning that I'm currently running unRaid version 5.0 beta 14

Link to comment

When I said I've been out of the loop on the UnRaid scene, I meant I haven't kept up with anything including the actual OS updates. Which is why I'm still running an old OS.


Crap out meaning the drive is dead.


I found my answer in the wiki as you mentioned with swap-disable, thanks a lot for the help!


Edit: Hrm, unfortunately it doesn't seem to want to work. I followed the instructions in the wiki but it doesn't like me swapping my cache drive to the Parity drive. Do I need to reformat/clear the Cache drive before I can swap it?


attaching screenshot below

Link to comment

Looks to me like all you have to do is select "Yes I want to do this" on the Copy line and then press the enabled "Copy" button.  It will start the swap disable procedure when you press the "Copy" button.  I've never done that myself because I always put in a NEW disk and rebuild with the existing parity drive.



You might wait for trurl to confirm above however.

Link to comment

Yep I tried that but it doesn't start the actual copying. I'm thinking it's because it's not a brand new drive and the cache still has some folders on it.

Hopefully trurl or someone else can advise you further.



Edit: Actually maybe clicking on the log button at the top and then try the procedure again you can then see what is output to the log when you try it.  If you can't figure it out from those entries someone else might.

Link to comment

Yep I tried that but it doesn't start the actual copying. I'm thinking it's because it's not a brand new drive and the cache still has some folders on it.


That is not an issue, disk is always overwritten.


Like Bob suggested, try clicking copy and look for any info on the syslog.

Link to comment

I don't see anything that stands out other than:

"unRaid kernel: md: disk0 wrong"


That's what it shows in the screenshot as well. Doesn't seem to want me to use that drive as the Parity. I've got two new drives on the way, should be here tomorrow. Hopefully that will clear up the issue. I appreciate the help guys and I'll give a status update once I try the new drives out. If you have any other insight it would be appreciated, thanks again!



Link to comment

My steps are as follows:


Currently the array is stopped. I unnassigned both the parity drive and the Cache drive. I assign the 3Tb cache drive as the Parity and the old Parity drive as Disk 5 (which is the drive that died on me). However, as soon as I assign the cache drive as the parity it shows up as "Wrong" under Parity and will not continue once I hit copy.


I'm terrible with words, I hope this makes sense.

Link to comment

Just in case I wasn't clear, I meant for you to actually start the array with everything assigned like before but without the cache drive assigned. The purpose of starting the array is to get unRAID to "forget" the cache drive. Did you actually start the array?

Link to comment

Hey guys just wanted to give a status update.


I got my new drives in today and was able to swap the dead drive with the parity and my new 4 Tb as the parity. Just hope the rebuild goes well :P


For some reason it just didn't want me to move Cache drive to parity...anyway thank you so much for all of your help!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.