[SOLVED] Slow Parity check, should I be worried?

Recommended Posts

I normally run a parity check once a month and get around 90MB/s finishing on about 118MB/s going on the last check.


Today the parity check is running super slow around 30MB/s and also noticed slower network transfers. Could this be a indication that something is failing? Never had any errors previously after parity check.


I rebooted the machine, made no difference. Will leave the parity check to run and see how long it finally takes to finish but has got me worried. Running v5.0.5 Plus (should I upgrade to 5.0.6?)


System detail are below:

System: - 

CPU: AMD Turion(tm) II Neo N40L Dual-Core @ 1.5 GHz

Cache: 256 kB, 2048 kB

Memory: 8192 MB (max. 8 GB)

Network: eth0: 1000Mb/s - Full Duplex

Connections: One




Link to comment

Disk doesn't look very healthy, I would replace it.



  1 Raw_Read_Error_Rate    0x000f  119  093  006    Pre-fail  Always      -      211432568

  3 Spin_Up_Time            0x0003  094  094  000    Pre-fail  Always      -      0

  4 Start_Stop_Count        0x0032  100  100  020    Old_age  Always      -      1010

  5 Reallocated_Sector_Ct  0x0033  096  096  010    Pre-fail  Always      -      5136

  7 Seek_Error_Rate        0x000f  040  035  030    Pre-fail  Always      -      4552676034756

  9 Power_On_Hours          0x0032  078  078  000    Old_age  Always      -      19825

10 Spin_Retry_Count        0x0013  100  100  097    Pre-fail  Always      -      0

12 Power_Cycle_Count      0x0032  100  100  020    Old_age  Always      -      25

183 Runtime_Bad_Block      0x0032  099  099  000    Old_age  Always      -      1

184 End-to-End_Error        0x0032  100  100  099    Old_age  Always      -      0

187 Reported_Uncorrect      0x0032  036  036  000    Old_age  Always      -      64

188 Command_Timeout        0x0032  100  096  000    Old_age  Always      -      6 6 6

189 High_Fly_Writes        0x003a  091  091  000    Old_age  Always      -      9

190 Airflow_Temperature_Cel 0x0022  076  060  045    Old_age  Always      -      24 (Min/Max 18/37)

191 G-Sense_Error_Rate      0x0032  100  100  000    Old_age  Always      -      0

192 Power-Off_Retract_Count 0x0032  100  100  000    Old_age  Always      -      17

193 Load_Cycle_Count        0x0032  045  045  000    Old_age  Always      -      110673

194 Temperature_Celsius    0x0022  024  040  000    Old_age  Always      -      24 (0 18 0 0 0)

197 Current_Pending_Sector  0x0012  100  091  000    Old_age  Always      -      0

198 Offline_Uncorrectable  0x0010  100  091  000    Old_age  Offline      -      0

199 UDMA_CRC_Error_Count    0x003e  200  200  000    Old_age  Always      -      0

240 Head_Flying_Hours      0x0000  100  253  000    Old_age  Offline      -      3226h+49m+11.275s

241 Total_LBAs_Written      0x0000  100  253  000    Old_age  Offline      -      6385386092

242 Total_LBAs_Read        0x0000  100  253  000    Old_age  Offline      -      167404614012



Link to comment

I dont really understand the report but have noticed some odd behavior so might as well swap it out, think I have a spare 3TB WD Red still in a box.


Is it a case of power down, replace disk, power up and start array for it to rebuild new disk?

The key attribute is the reallocated sectors at 5136.  Not good.


That's the correct procedure (after assigning the new drive)  but I would also add make sure that you don't disturb any other sata connections or power connections when swapping out the drive


Sent from my LG-D852 using Tapatalk


Link to comment

I will replace the drive and possibly bin if its that bad. So it turns out the WD Red I have is a 4TB and I know remember I never got round to updating the bios on my HP N40L so will swap it with this and at the same time replace the cache with a 240gb SSD I have.


I will run SMART check on the other drives and see if the same error appears on any of them.

Link to comment

unRAID Disk 1 disk utilization: 19-05-2016 18:18


Warning [sERVER] - Disk 1 is high on usage (88%)

WDC_WD40EFRX-68WT0N0_WD-WCC4E0732517 (sdc)


Any way to span the data on to other drives I think all drives are set to high water

The shares get set to highwater.  Drives don't.  Personally, I wouldn't particularly worry about it unless you it keeps increases in which case you want to look at the share's split levels & included/excluded drives.


But if you really want, the only real way to balance things out is to move files / folders from /mnt/disk1/xxxxx to /mnt/disk2/xxxx  (don't move from /mnt/disk1/xxx to /mnt/user/xxx as you'll corrupt the file)

Link to comment

Feeling quite optimistic, replace disk 3 with a 4tb drive I had but its a green drive not red :shocked: also replaced the original 250gb cache drive that came with the N40L with a 240GB SSD.


Rebuild will probably take around 7 hours so will leave it for tonight and rely on amazon prime instead of plex lol.


Thanks for all the help will mark as solved if no further issues.

Link to comment

All done and dusted! Can't believe how painless it was, other than the time taken to rebuild which is totally worth it!


Not so sure about having a 4tb WD Green in there and the other seagate drive doesnt exactly leave me with much confidence as they were bought the same time and reading on amazon a lot of people have said failed around 2 year mark.


Might have to invest in 2 more 4tbWD Reds next month, apply bay mod firmware update and make use of 6 drives.


Oh and the SSD cache has worked wonders, getting 100MB/s transfers to cache compared now so very happy!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.