VirtualBox goes BSOD when using Red Hat VirtIO Ethernet Adapter bridged adapter


8 posts in this topic Last Reply

Recommended Posts

I've adopted Unraid and even imported my physical machine into a Windows 10 KVM.

 

I use VirtualBox for virtualization. I needed to fire up one of the Virtualbox VM and discovered that the Red Hat VirtIO Network adapter can't be bridged because if I do, I get a BSOD with the following error:

 

Stop Code: driver_irql_not_less_or_equal

What Failed: VMMMR0.r0

 

This error is reproducible.

 

Windows 10 KVM pc-i440fx-2.5 OVMF

Network Bridge: br0

 

Download and Install VirtualBox for Windows

Create a virtual machine, I selected Ubuntu 64

In network settings, I selected Red Hat VirtIO Ethernet Adapter

Selected Ubuntu Server ISO

 

Is there a way that VirtualBox will work using the onboard NIC? If I don't select a network adapter, the VirtualBox machine boots and works, but without network.

 

Please let me know.

Link to post

Yes thats exactly right.

 

Unraid => Win10 VM => Virtualbox

 

It's weird, I get it, why even bother with with Virtualization apps when Unraid has better virtualization than VMWare or VirtualBox.

 

I have a few important Ubuntu based VirtualBox VM that I need to run inside a Windows 10 VM. And my transition to going all in for Unraid was great until I hit this wall.

 

Again, the problem is using the Red Hat VirtIO Adapter with VirtualBox in bridged mode causes that BSOD. I was able to reproduce it even on a clean Windows 10 KVM.

 

I like having Virutualbox because I'm able to move my Ubuntu based VM and are so portable. It just doesn't play nice with the KVM network adapter in bridge mode.

Link to post

Do you realise that you can use VirtualBox .vdi files when running a VM directly under KVM?  I do this with some VMs where I want to be able to have the portability of being able to move the vdisk file to run in VirtualBox under Windows 10 on another machine.

Link to post

I looked at some guides and all point that the VirtualBox VDI files need to be converted to RAW image files.

 

Do you happen to have a link that would show where to do this? I'm really interested with just making a KVM of the virtualbox machine I have.

 

Thanks

i do not have a link to hand but it is not difficult.

 

The main point is that you have to do is type in the full path of the .vdi file as the vdisk path rather than trying to select it via the GUI.    KVM/QEMU actually supports most of the different vdisk formats - it is merely the unRAID web GUI that limits the types offered.

 

If you do not already have the virtio drivers installed into the VM then you need to either force them to be installed while running under VirtualBox, or alternatively under KVM set the disk device to be of type 'sata' rather than 'virtio'.

Link to post

I should have just followed your advice from the beginning. I did get VirtualBox to run through a plugin instead of inside the Unraid VM. Works beautiful but can't console into it and no Unraid VM can run while it's in use. Maybe there is a way to make them both play nice?

 

Then I followed up on what you posted, created a SEABIOS machine and attached the VDI files from Virtualbox machine. It just works. I didn't even need to install no network drivers. At long last I can just completely adopt Unraid VM.

 

Thanks again for the advice. Still learned alot from all this.

Link to post

Just a follow up if anyone is interested in bridging a network adapter for virtualization, VirtualBox and VMWare. I've only tested this on VirtualBox in a KVM Windows 10 machine.

 

I noticed the TAP-Windows Adapter V9 is used for OpenVPN or VPN applications that use that adapter. I had recently setup an OpenVPN server and the thought occurred to use adapter as the bridge instead of the Red Hat VirtIO. Results are in and it gave me internet access to my virtualbox VM.

 

It's a workaround and I can live with it. I had previously tried to make a Loopback adapter and tried bridging that and couldn't make it work.

 

So now, if ever I need to bridge an adapter, I can use the TAP-Windows Adapter, or use any other adapter that can be used for means of giving the virtualbox VM access. Although now since using Unraid I really find the exercise of using virtualization software very pointless.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.