Jump to content
Spoir

Issues with Samba shares and Windows 10VM

4 posts in this topic Last Reply

Recommended Posts

Hello all, I'm pretty new to unraid. I've spent the last 4 days researching and testing out my new system for a NAS + Gaming VM setup. I am having issues with private and secured shares on my Windows 10 VM.

 

After exhaustive research, I have tried many things to get it running. So I'll state how I have it set up and what I've tried and hope someone has an answer.

 

Shares: Music, Movies, UserFiles (Private) UserFiles has a user with read/write access and a very simple password (1234)

 

Symptoms:

 

    Through file explorer, Windows VM can see and access both Music and Movies, but prompts for password for UserFiles to which it then fails (access denied). username: user, password: 1234

    Laptop (W10 as well, same version) prompts for password when accessing \tower and is able to read/write in all directories (including UserFiles)

    Server2012 VM can access all directories, is prompted for credentials for UserFiles and can access files.

 

Failed Attempts to resolve issue:

 

    Restarted both vm and unraid several times

    Created local user on W10 machine with matching name and password

    Created samba user with matching user to windows logon and password

    Cleared credential manager

    net use * /d (Even though nothing was listed)

    net use z: //tower/UserFiles \u:username

    Disabled SMB2 and SMB3 and restarted (and tried the other methods again)

    Changed workgroup on both ends to an all caps workgroup.

    Ensured Unraid was master browser

    Enabled the registry change to allow unauthorized access (can't remember the exact setting atm)

    Accessed shares with IP address: This actually works fine, but doesn't fix the issue of not being able to connect with hostname.

 

So I can access the private shares using \\192.168.1.2\UserFiles but not \\tower\UserFiles

Somewhere in my travels I lost the ability to have the shares populate in the network though :(

 

This lead me to think I am having a DNS issue, but not one I'm familiar with. My router is a brand new Nighthawk R6900 on stock firmware.

 

I would have thought that if it was a DNS issue that the other machines would be having the same problem, but they are not.

 

Anybody have other avenues to try? I am currently at work so I may be slow to respond to attempts. Thanks!

 

Share this post


Link to post

Unplugged from router, gave static IP to host. Added a binding in hosts to the tower and I can now access the shares with the username and password.

 

::)

 

Will investigate further. Seems to be a dns issue?

Share this post


Link to post

Samba/SMB does NOT use dns!  It uses the Local Master Browser.  (You have set your server up to be the Local Master?  'Settings'  >>  'SMB' icon  >>  'Workgroup Settings')

 

Here is this post from LimeTech and a few that follow it is a discussion of why Samba sometimes has problems like this:

 

        https://lime-technology.com/forum/index.php?topic=26412.msg231122#msg231122

 

You might also install the "Local Master" plugin from the developer of the Dynamix GUI.  You can find it here:

 

      https://lime-technology.com/forum/index.php?topic=36543.0

 

It will provide with information about which server is the Local Master on your Network.  You REALLY want your server to be the Local Master!

 

 

Share this post


Link to post

unRaid was set as local master and I did have a little Yoda head the entire time. Even had it send alerts if anything failed. Still haven't pinpointed the issue yet, but the hosts file did the trick.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.