Jump to content

Permissions broke on folder (Added more info)


Recommended Posts

I have a Backup share on my server that's mapped to the B:\ drive in Windows 10. I have a Dell OptiPlex desktop and a Dell Precision laptop to both backup to folders on this share. See below for folder structure.The Windows Backup (Win7 Version) uses the UNC paths for backup. 

  • \\Tower\Backup -> B:\
    • \OptiPlex
    • \Precision

The Precision is set to backup Mondays at 0800 and the OptiPlex is set to backup Tuesdays at 0800. The Precision backed up successfully but the OptiPlex failed, even after running the new permissions tool on the Backup share. I tried creating a .txt file in that location, and could not since I no longer had permissions. Although i was able to delete the backups through the Windows Manage Backups settings. I had to use Dolphin/Krusader to delete the folder with broken permissions. I re-ran the Windows backup and it's working now. Any idea what happened?



Link to comment
  • 3 weeks later...

The issue has now reversed, I can backup the OptiPlex successfully and create new txt files in the location. But now I cannot backup the Precision or create new files in the Precision folder. The Precision is my main computer and would need to backup close to 600GB of data, I really do not want to delete the backups and back it up again. Since the issue seems to keep persisting, I would really like to figure out what keeps happening. Any ideas?

Link to comment

At some point between repairing permissions, creating a text file successfully, and running the Windows Backup permissions break. I only have two users root, and mine. I created a txt file successfully and then ran Windows Backup. At some point something happened and I tried deleting that text file and it errors saying I need permission from TOWER\myusername. 

Link to comment

I'm really hoping someone who sees this has some advice.


I have continued to troubleshoot. Running the new permissions tool at just the right time allows Windows to backup my computers. It seems as though just before Windows starts copying files I run new permissions and it'll allow the computer to be backed up and files written to that share. Part of my troubleshooting this weekend was that I noticed on this share I received the incorrectly ordered permissions error. Further research revealed I probably had enhanced OS X interoperability enabled, I disabled this since I don't have a Mac anymore and that fixed the incorrectly ordered permissions error. Everything seemed solid, I was able to create more troubleshooting text files and backed up my computers. 


Until today. The backup failed and I attempted to delete some of the troubleshooting text files I created earlier. One said I needed permission from TOWER\nobody and the other said I needed permission from TOWER\myusername. I am stuck and I'd like to get this resolved. I thought I had attached my diagnostics and logs earlier, but did not so they are here. 


The full paths I cannot write to, but can do so in the level above or further down.

  • B:\OptiPlex3020\OPTIPLEX3020
  • B:\Precision7510\PRECISION7510

Windows is set to backup using the UNC paths of:

  • \\\Backup\OptiPlex3020
  • \\\Backup\Precision7510

The next level of folders with all caps was created by the Windows backup tool. During my troubleshooting today, I created a new share, copied everything from the old share to the new share and repaired permissions on the new share and attempted a backup. The backups worked, however shortly thereafter the permissions issue reappeared on the new share. 





Permission Error.PNG

Link to comment
  • 10 months later...


This topic is now archived and is closed to further replies.

  • Create New...