Jump to content

[SOLVED] Mover not moving files/cleaning cache


hardcore_2031

Recommended Posts

My problem is related to the Mover not moving data off of the cache drives.  Because of issues I've had with cache in Unraid, I'm looking to *ideally* only have the domains share use the cache drive, so my VMs would run from the SSD, however if that is not possible, I'd like to migrate all data off the cache disk and remove the final cache drive from my system. Either of these would be acceptable solutions.

 

I included my diagnostics below, but I'll include some additional info here in case it helps solve the mover issue.  Initially when I set up my Unraid server I was using 2x 120GB SSDs in a redundant cache.  Recently one of those drives died so I'm left with a single cache drive with no redundancy.  Because of this I don't want any actual data stored on the non redundant cache, and am really only comfortable with my VM vdisks living on the cache ssd.  I created an SMB share who's path points to /mnt/user  This allows me to see all of my shares from a single drive mapping in windows (in cases where that's convenient).  From everything I read on these forums , creating shares like this default to not using the cache drive, but since a share mapped at this level doesnt show up in Unraid's user shares, I can't tell for certain what that share's cache use situation is.

 

Things I've tried that I found while searching the forums:

1. The domains share has its "Use cache drive" setting set to prefer, all other drives are set to no

2. Enabled logging for Mover.  To me all I see is Mover starting then immediately stopping, no error codes

 

Any help would be appreciated as I am at wit's end.

prism-diagnostics-20180530-1317.zip

Link to comment
26 minutes ago, hardcore_2031 said:

1. The domains share has its "Use cache drive" setting set to prefer, all other drives are set to no

 

Turn on help on the cache settings. Cache: No means new files written to the share will go directly to the array, and the mover won't touch files already on the cache for that share

 

What you want is Cache:Yes and run the mover, then make sure no new files are written to the cache by turning it back to Cache:No.

Link to comment

Good call, the "No" may very well be why the Mover isn't taking anything off that disk.  However when I try to switch one of my shares to "Yes" and apply it switches right back to "No"

The output to the log when doing this is:

May 30 19:20:09 PRISM emhttpd: req (21): shareNameOrig=Multimedia&shareName=Multimedia&shareComment=&shareAllocator=highwater&shareFloor=0&shareSplitLevel=&shareInclude=&shareExclude=&shareUseCache=yes&cmdEditShare=Apply&csrf_token=****************
May 30 19:20:09 PRISM emhttpd: error: put_config_idx, 595: Read-only file system (30): fopen: /boot/config/shares/Multimedia.cfg
May 30 19:20:09 PRISM emhttpd: Starting services...

 

Link to comment
  • 2 weeks later...

I wanted to follow up on this in case anyone comes upon this again in the future.  My problem *was* a smoked USB stick.  I tried several scanning methods to repair errors and all yielded no luck.  I RMA-ed the old one, bought a new stick, and did my once a year license transfer, and now I'm able to set the "use cache" settings correctly for all shares.  Mover is now working perfectly.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...