Jump to content

Unraid melting down - please help


Recommended Posts

Long time unraid user, really never had any huge problems until recently. Basically I started having streaming issues with a new drive that I put in, I dealt with it for a few weeks but it started to get bad so I tried to verify that the drive was having issues and sure enough any video files I tried to play from that drive (drive 10) would stutter. So I ordered a new drive and sent that drive back. Got the new drive in, replaced it in unraid and the rebuild started, got about 20% in and said there were read errors on the new drive. I didn't think much of it at the time because I have had DOA drives before, so sent that one back and ordered yet another new drive. Put the new one in and failed after about 10%. Now I am thinking it's hardware, I've looked in the logs a few times during all of this and didn't see anything alarming so I though maybe it was a cable or something so I reseated all of the sas connectors to the backplane and the expander and the HBA. Started a rebuild again, same thing. Somewhere along the way errors started creeping in to the logs , lots of retrys, etc... So again I shut it down, re-seated everything and replace the SAS cables for the row on the backplane that contained the new drive. Started rebuild, same thing. Now it starts to go downhill, after starting the rebuild for the umpteenth time, all of a sudden another drive fails. I have two parity drives so I'm kinda okay but I'm seeing a pattern develop here. Which leads me to right now. I moved the new drive to another bay and the array is rebuilding with the first replaced drive being emulated and one drive marked as dead. I have no expectation that the rebuild is going to work and I'm scared s$@#$less that my unraid is going to collapse in on itself. I'm attaching latest syslog, any help would be unbelievably and greatly appreciated!


Link to comment

Well miracle of all miracles, somehow overnight the rebuild continued and is now at 75% and the constant stream of errors in the logs have stopped, at least for now. I have used this HBA for about 4 years now with no hickups at all, I do have a backup controller but it's the same one, is this for sure a controller issue? Also I wasn't sure what to post really, I can grab the full diagnostic if that will help.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...