Jump to content

[solved] Brand new disk keeps failing on data rebuild


Recommended Posts

I had to replace a 2 TB disk that was faulty. I precleared the new 4 TB drive (parity is 4 TB as well) and everything was fine. Then I started the data rebuild with the new drive. About halfway through there are read errors and UnRAID marks the disk as faulty. Tried two times already.


The old and new drive are connected to the same port on the Marvell RAID controller. Unfortunately all SATA ports are in use so I cannot try another one.


Any suggestions? Could this be the SATA controller that cannot handle 4 TB drives (but preclear works?!)?



Link to comment
6 hours ago, johnnie.black said:

Disk dropped offline so there's no SMART, but it's possibly the SASLP, since these are known to drop disks.

OK, thanks. I just connected the disk to a SATA port on the mainboard and started a data rebuild.

The controller's been working fine for five years but maybe it can't handle the new drives. Will probably need to replace it soon.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...