Jump to content

VM's booting straight to EFI shell after force stop


em1917

Recommended Posts

I lost power a while back and some VM's didnt recover. Since that time, I have noticed the VM's do not stop and if I force stop them when I try to boot them back up the VM will only load into the EFI shell. I have loaded the drives into a rescue disk and ran FSCK on the files systems and there were no errors. Does anyone have an idea?

Link to comment
  • 2 weeks later...

I'm not sure if this is helpful, but I had an issue recently (almost the same day you posted actually) where my hackintosh VM that has run fine for almost a year crashed while I was afk, then booted to UEFI shell and would not continue from there. I tried everything I could find in the forums to no avail. I backup vdisks weekly and ended up copying over a backup and it booted fine from that, I just lost a few days worth of stuff.

 

Now it's a couple weeks later, I just circled back to delete the non-working vdisk from my cache drive. I noticed in the terminal that the broken vdisk's permissions are set to 644 and ownership of the files is root:root. On all of my working vdisk.img files, for this VM and others, it's 666 or 777 permissions and ownership is root:users. 

-rw-rw-rw- 1 root   users 64424509440 Jul  1 15:25 sierra-rebuild.img
-rw-r--r-- 1 root   root  64424509440 Jun 18 08:31 sierra10.12.5.img

The first file, sierra-rebuild.img works, the second one sierra10.12.5.img does not. I haven't tried changing the permissions and booting the old one, at this point it's outdated and I don't want to shutdown the VM right now to try it.

 

I'm really not sure what permissions are recommended/necessary for vdisk images, if this was actually what caused my problem, or if there's any reason a crash could result in changed permissions of the vdisk. Maybe 644 and root:root should work and it was another issue entirely. I changed a lot of things on my server during the week it happened, upgrading both unRAID and hardware in the array.

Link to comment
  • 3 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...