Jump to content

LSI SAS9340-8i Unable to discover more than 1 disk


Recommended Posts

Hardware specs: 
https://www.amazon.com/gp/product/B07CL2STVS mini-SAS -> Sata cables
Intel i3 8100
16gb DDR4
GIGABYTE H370N 

IBM Lenovo ServeRAID M1215 (equivalent to LSI SAS9340-8i)

 

Disks:
3x 6TB WD Red Pro
3x 3TB WD Red Pro
512GB Samsung 970 PRO (NVME)
256GB Samsung 860 PRO (SATA)

All in a SilverStone DS380B

 

The first issue I ran into was a SMBUS issue where I had to tape off pins 5 and 6 in order for my system to even start POSTing. Without it, the fans would spin on full blast and there would be no display output. 

 

Once that was solved, I ran into another issue where my motherboard would hang on POST with the typical POST screen, but only displays "Press DEL to enter setup". If DEL is hit, "Entering Setup" appears, but nothing happens. I don't have any way to figure out the post code since theres no onboard LED display, but it only occurs when theres more than one drive attached to a single SFF-8643 port. I tried many different drives (combination of physical/ssd) and was unable to get it to boot. 

 

Actually while I was writing this message, it finally finished the POST, but only one disk is visible in the BIOS. It seems like its hitting a 5 minute timeout or something similar before it skips over the drive and moves onto the next?

Previously I ran this backplane with a Supermicro AOC-SAS2LP-MV8 HBA, but its performance was horrendous during a parity check, so I don't believe its the backplane, but there could be a compatibility issue with the two.

 

Update:
Enabled Legacy Bios in the UEFI menu, then forced the Legacy BIOS under the CSM support settings, and I could get the card to boot in a reasonable time. Attached is a screenshot of the syslogs that appear when the drives are being detected. The logs are with two disks attached.

 

Thanks for any information you can give.
 

IMG_20180617_182503.jpg

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...