Jump to content

Noob: Tried to passthrough video now I can't see anything on actual server


Recommended Posts

Hi guys,

I am sorry if this is answered somewhere where I couldnt find it, but ive been searching for hours now and I am hoping someone can point me in the right direction.

I just started working with Unraid tonight and I attempted to install Ubuntu as my primary VM. I set up the VM to have GPU passthrough and left clicked create, and my screen went blank. I thought it might be just installing but it never came back up.  So I got on another computer to try to log into the server and I can see through the VNC on the server that its running fine and Ubuntu is ready to be installed.  Now however, I still cannot get any visuals on the primary unraid server. It doesnt matter if I reboot, clear the CMOS, remove the VM i installed. I still have a blank computer.

I can log into it just fine and do everything but I can't get the GPU to output anything.  I don't have an onboard video card, but I do have two GPU's. I've tried connecting to each of them in all of the DP + HDMI ports to see if something else wonky is going on.

Hopefully someone can give me a bit of guidance! I'd really like to get this moving.




Link to comment

Can you get to the GUI?  If so,  Tools   >>>>  Diagnostics 


Can you get to the server via SSH?  If so, log in and type    diagnostics  at the command line prompt.   That will write the file to the  logs  directory/folder on the flash drive.  


Upload the file with your next post.

Link to comment

Hi there,

Thank you very much for your quick response. That was crazy!

I actually was able to fix this and I am a bit embarrassed about it, but whatever, here we go.

My system has an Onboard graphics card that it kept trying to boot up through after I didn't pass the GPU properly. So, once I realized that I plugged an HDMI cable into the onboard graphics and saw that it indeed as booting and loading just fine, I had just broken the GPU Passthrough it was back to normal.

I followed the https://www.youtube.com/watch?v=mM7ntkiUoPk Spaceinvader one GPU passthrough video to get it fixed!

Thanks very much for your help, sorry for such a noob question =)


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...