Jump to content

(Solved) Stuck at array starting after new config


uraid

Recommended Posts

Hi there,

2 days ago I got a new drive and added it to the array without preclearing first.

After it got cleared by unRAID I noticed that it is defective (reallocated count getting higher as I write to it and pending sector count doesn't go down).

I wanted to RMA it, so I got into removing it from the array.

 

I first tried the approach of clearing it to zero from this guide (The "Clear Drive Then Remove Drive" Method):

https://lime-technology.com/wiki/Shrink_array

Woke up the next morning and it cleared only 30GB out of the 8TB drive..

So I killed the 'dd' command and tried the first approach with rebuilding parity.

The problem is that after I did 'Tools->New Config' and unassigned the drive, the server is stuck at 'Array starting'.

 

Docker was off but VM was on when I clicked Start Array.

I rechecked my assignments and am sure they are as previously assigned except the one drive I want out (disk6).

Please help me as I don't want to reboot the server and lose everything :/

 

Thanks a lot in advance!

zeus-diagnostics-20180727-1218.zip

 

EDIT: Also I remember that when I tried the 'clear drive then remove method' I forgot to include all the other drives but this one from all the shares (did change the global share settings though).

Also, I had problems stopping the array after that procedure because it showed that the processes of the server wanted to access the unmounted disk6 (unmounted and then 'dd' zero on it).

I had to hard shutdown the server using the power button but the array started just fine after that (before the new config).

 

EDIT2: I also had an auto-starting script to rclone mount to /mnt/disks/<DIR> that could have compromised the new array start.

I unmounted it after clicking start array but think it is too late cause now it's stuck.

 

Untitled.jpg

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...