Jump to content

[SOLVED] No internet access

Recommended Posts

My unRAID server can't access the internet. I've searched the forums & checked my network but I can't find anything wrong. 


Pinging google / github / etc from console doesn't work.


I run a physical pfSense router, which runs a DNS (I use dnsmasq blocking, but have that disabled to rule out that that was the problem, backend DNS is )

Pfsense box:


DHCP pool:

unRAID server:

docker network:


This started happening after I updated my pfsense firmware, but no other devices on my network seem to have any issues. 



Diagnostics are attached if anyone wants to take a look, hopefully it's something simple I've overlooked. 


Edited by tbrasser
Link to comment
17 hours ago, John_M said:

The first and most obvious question is can you ping your router?


Second question: why does your docker network have a 25-bit netmask while everything else has 24 bits?


What is the output of


typed at the unRAID command line?


1. Pinging my router works fine:

root@Server:~# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.255 ms
64 bytes from icmp_seq=2 ttl=64 time=0.294 ms
64 bytes from icmp_seq=3 ttl=64 time=0.143 ms
64 bytes from icmp_seq=4 ttl=64 time=0.202 ms
--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3095ms
rtt min/avg/max/mdev = 0.143/0.223/0.294/0.058 ms

2. Oh yeah, it's still on a /24 subnet, the /25 is the DHCP pool for the br0 docker network:

Subnet: Gateway: DHCP pool:  (128 hosts)



17 hours ago, Frank1940 said:

Fill in the blanks for a DNS server addresses.  You can use     and      as they are Google's DNS servers and they work anywhere in the world.  

Can't ping google's DNS servers either.



However while typing this comment I took a look at my pfsense config again, and found that the only thing different between the unraid server and the laptop I'm typing this comment on now is that I've had my laptop configured to go through an openVPN interface,   I just tried to add the unraid server to that alias list and now it's connecting again. weird.


So it's safe to say that the problem is not at the server, it's in my router config.   Thanks for the reactions anyway, I'll be reconfiguring my router/firewall now to tackle the problem.

Link to comment
  • 1 year later...

I had the same problem (no ping to possible, but local access works). Finally I found out that the Tips and Tweaks Plugin killed my network settings. I do not know why, but after removing the "eth0" of the list and rebooting the machine, the internet was accessible again:



I think the plugin is overwriting my settings on boot causing this error. I will post this in the plugin's thread, too.


EDIT: Sometimes even the local network did not work. If this happens it helped to login through the server itself (IPMI or physical) and after log in with "root" and my password, I used this command to re-apply the network settings:

/etc/rc.d/rc.inet1 restart

After that I was able to open the webclient again.


Edited by mgutt
Link to comment
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...