Jump to content

HTC Vive disconnecting


Recommended Posts

So im fairly new to unraid but ive got the basics down, i have all my shares setup and VMs all working fine. On my VM i have passed through a USB 2 and USB 3.0 bus and all is working. If i plug my vive into this, it works for arround 1-10 minuites before it looses tracking. I have tried the obvious, disabling the camera, cleaning base stations, all 4 usb ports that are passed through, chaning USBs, using it in either seated mode or room scale, ignored the hub.


Any advice would be greatly appriciated.

Link to comment
3 hours ago, Zevulos said:

On my VM i have passed through a USB 2 and USB 3.0 bus and all is working.

Do you have any other USB controllers you could try passing through?  It sounds like you have a similar setup to how I do things, with my VIVE (passing an entire USB controller and letting Windows handle drivers for VIVE, so I don't have any "silver-bullet fixes" for you.  Out of curiosity, if you plug in a different USB device into the passed-through ports does it disconnect after ten minute approximation?  Anything show up in your unRAID log file, when you lose tracking?


My train of thoughts were, do other devices disco on the passed through controller? Are there any other symptoms which might help us troubleshoot the issue? Are there other USB controllers to try passing, and if so do they do the same thing?


The VIVE is on the USB3 controller right?

One last thought, are the tracking stations reporting current on their firmware by vive software? I know mine complain about updates, but warn that out of date firmware could cause tracking issues. 



Link to comment

If I use the same USB bus I have passed through it works with any other device perfectl. I haven't checked the log file so I'll do that later on. There are 2 USB controllers passed through and both loose tracking.i have tried it on 3.1 and 3 and yes it thinks all the firmware is up to date

Link to comment

At this point, if I had a spare drive in your position, I would make a bare-metal Windows install. Setup VIVE on the bare-metal and see if the drops happen there -- try to rule out unRAID from the mix. Or perhaps if you have a spare pci/pcie slot you could get another USB controller to pass through and see if it has the same issue. 


Running out of ideas to try, sorry.  Good luck.

Link to comment
15 minutes ago, Zevulos said:

do you have any pic or pie controllers you'd recommend? 

Sorry I don't, I would scour the forums for what others have used, and have good luck passing through.  For myself, I haven't had to pass through a PCI-USB controller yet so I have no experience with what does, or doesn't work, well. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...