Jump to content

VM Manager won't start


Recommended Posts

Hello, I tried to add a new drive in the Cache Pool for protected cache, but it did show an error putting the new drive on pool (something with bad uuid, I don't remember the error exactly), so I had to remove it again and leave back the initial SSD alone. All the files are still there, and the docker wasn't starting unless I created a new docker.img file, deleting the old one. I then reinstalled my only container mariadb and it worked fine with all the databases. But the VM Manager also won't start. I don't want to lose my VMs, I don't remember the settings of each one, I only have the vdisks. How can I fix it? If I delete the libvirt.img and recreate it, the VMs will be gone from VM manager or not? How can I recover from this disaster? Please help.

Link to comment

Have you checked that you have the correct path for the libvirt.img file in the VM Manager Settings?  Note that it needs to be the full path including the filename (some people seems to have it somehow set to the folder only).


in the worst case where you do need to create a new libvirt.img file, your VM vdisk will still be intact and all you would need to do is recreate the VM Configurations pointing them at existing vdisk files.   Also if you have the CA Backup plug-in installed then it would have backed up the libvirt.img file.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...