Unraid 5.0.6 crash, won't restart (getting "VFS: Insert root floppy and press enter" prompt)

Recommended Posts

Looking for advice - during a data transfer between two Unraid servers (both running 5.0.6), the source server (TOWER) crashed. 


Tried to restart, and I'm getting the same situation described in this post, down to getting the line “VFS: Insert root floppy and press enter”:




Same with that previous post, if I press enter at that point, then kernel panic.


I've restarted the machine twice, no change. I've been running Memtest86 for 80 minutes so far to see if anything comes up, but it hasn't reported any errors yet.


I plugged the USB key for TOWER into a Windows 10 workstation and can see the files on it. I ran a checkdisk on the USB key with no errors detected.

I've emailed tech support at Lime for advice but I thought I would ask for guidance here while I'm waiting to hear back.


I really don't know whether the problem is with the flash drive (as with the topic that I linked to) or something else on the hardware side and I don't how to approach isolating the cause.


Could I simply install v6 onto a new USB flash drive as a trial and resurrect my array and recover that way? And then get a replacement key from Lime for that new flash drive? Note that the crash this morning obviously wasn't a clean shutdown - but no data was being written to TOWER at the time, it was the source of the files being copied. If it's relevant, TOWER has 14 data drives plus 1 parity drive, and I have the drive assignment info stashed.


Hope that you are all having a happier New Year's Eve than I am right now. :)

Link to comment

First, the (optimistically) good news - I backed up the files from the current USB key and then refreshed it as is (reformatted the USB, copied over the files from the original 5.0.6 install zip, made it bootable, restored the config files) and flipped the switch. Everything came up, green balls against all of the drives, and a parity check underway that should finish sometime tomorrow. So, this is encouraging.


For hardware, I've got:

ASUS F1A75-V Pro Socket FM1 AMD

AMD A4-3400 2.7 GHz Socket FM1Seasonic X-660 Modular 80PLUS Gold PSU

Mushkin Silverline 4GB (2xGB) DDR3 1333 MHz

G.SKILL Ripjaws X Series 4GB (2x2GB) DDR3 1333 MHz CL9 Dual Channel

Antec DF-85 Dark Fleet Tower Case + 5-in-3 cage

Supermicro AOC-SAS2LP SATA controller card (I think that this was the one)

13 internal drives (various brands and sizes) + Samsung SSD EVO 250GB

Kingston DataTraveler DT108 4GB uRDrive USB 2.0 Flash Drive


Would this be okay for V6?


Link to comment

I think 2GB RAM is the minimum spec, but I really consider 4GB to be more realistic. Should be OK if you don't try to run any VMs or many dockers. Could be that controller will be unreliable in V6 but maybe not. I seem to remember it is more of a problem if you enable IOMMU (VM passthrough) in the BIOS. Maybe someone else will have an opinion on that.

Link to comment

No real expectations at this point for having anything more than NAS capacity.


Re the Supermicro card, it was their AOC-SASLP-MV8 card that I added, not the one that I listed above. Don't know if it makes any difference; if IOMMU was disabled by default, that's how I would have left it.


Thanks for the advice, btw, much appreciated.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.