unRAID 5.0.6 Won't recognize new disk

Recommended Posts

Short version: I bought an 8TB WD red to upgrade my parity disk.  The old parity (5TB WD red) was unassigned, system was turned off, new drive added, and restarted.  But no matter what I do it won't recognize the new drive via the webui.  Thought it might be faulty, so I took it back and got a new 8TB red, but same result.  Any ideas?


Long version: I've had the server for 4 years and have added 5TB drives to it (mostly WD Greens with headparking disabled) with no issue over the years.  Last week, I found some of the blue lights above the Icy dock bays off and the server was telling me it couldn't find the parity disk and another data disk.  I discovered the disks were fine, but the something with the Icy Dock bay failed.  No biggie as I only had 6 disks total and 4 icy dock bays with 5 slots each (20 total).  So I moved the disks to new slots and all the disks worked.  But somewhere in the process I unassigned the parity drive.  I'd already bought the new WD red 8TB so figured it would just be a good chance to upgrade the parity disk.  At first it recognized the 8TB wd red, but I took it out to disable headparking (I know, the Reds are already set to 300 seconds) and also to wait for a covenant time to take down the array to rebuild the parity. 


I couldn't get WDIDLE to work on the 8TB red so I gave up and figured I would live with the 300 second head parking, but afterward the server stopped recognizing the new 8TB drive altogether.  Thought it might have failed so I exchanged it for a new 8TB red.  But same result with the 2nd 8TB red.


At this point, the server is running fine, but doesn't have a parity disk.  The old parity (5TB red) is listed as basically an unformatted 6th disk.  I would like to figure out how to get the server to recognize the new 8TB red so I can make it the new parity disk.  After that, I will format the old 5TB red to be a data disk.  Any help is MUCH appreciated!!  Thank you.

Link to comment

Thank you for responding. I know “just enough to be dangerous” here.  I can log in via telnet with root etc., but Linux commands are my weakness.  Could you quickly tell me how to view the disks in bios/run diagnostics? I will then view and post the same. 


Thank you in advance. 

Link to comment

Oops  You're running version 5


just copy the syslog and post it here

cp /var/log/syslog /boot/syslog.txt


Saves it to your flashdrive.  To see if the BIOS recognizes it, many will itemize the drives when it does the POST.  Barring that, looking at the available drives in the Boot Order will also itemize them.  If it doesn't, then zero chance unRaid will.

Edited by Squid
Link to comment

This was odd.  I just put an old WD 1TB drive in the same bay as the 8TB was in, and the web ui recognized it with no problem.  The 8TB red is WD80EFAX.  I then put the 8TB in the next slot and I can now the webui can see that too.  I allows me to assign it to the parity and it appears I'm good to go now.  Just need to figure out when I have time to take the array down for a couple days to run the parity sync (my young kids will not be happy ;-)  Thanks again for taking the time to reply.  Much appreciated. 

Link to comment

 Would you recommend that I get the new parity drive up and running before I upgrade the OS?  Or will it not matter? 


 I understand that version six has certain plug-ins, such as pre-clearing, that may speed up the process of upgrading the parity drive.  Will version six re-create the parity drive faster than version five? 

Link to comment
2 minutes ago, cpearcy said:

 Would you recommend that I get the new parity drive up and running before I upgrade the OS?  Or will it not matter? 


 I understand that version six has certain plug-ins, such as pre-clearing, that may speed up the process of upgrading the parity drive.  Will version six re-create the parity drive faster than version five? 

It should not make any difference whether you update the parity drive before or after doing the upgrade.  Performance should be roughly the same.


Note that pre-clearing is never required with v6 as it can clear a disk (if required) without taking the array offline.   The prime purpose of the pre-clear plugin in v6 is to provide a way of ‘stress-testing’ a disk before adding it to the array.

Link to comment

The only time Unraid requires a clear disk is when ADDing a disk to a new data slot in an array that already has valid parity. This is so parity will remain valid since a clear disk (all zeros) has no impact on existing parity. So as you can see you don't need a clear disk to put in the parity slot.


However, it is a good idea to test any new disk and preclear is one way to do that. You can use the preclear script on V5, or you can test using the disk manufacturer diagnostic available for free download.


Probably doesn't matter whether you do it before or after parity replacement, but I usually try not to make more than one change at a time and only change things when my array is stable.


You mention you are currently running without parity and your original parity disk is unformatted. Parity is always unformatted since it doesn't have a filesystem. Does Unraid think you have a missing parity disk? Probably not, I am guessing you must have done New Config if it let you start the array with it assigned as disk6. Or is it assigned to that slot?

Link to comment

I’d certainly like to temporarily go back to my 5TB parity if possible, so I can upgrade to the 8TB at a later convenient time.  Is there an easy (fast) way to do this?


I was following the standard instructions for upgrading the parity. I had unassigned the 5tb as the parity when I was going to upgrade to the 8tb.  I can’t remember exactly what happened thereafter, but the 5tb parity is now listed as disk 6 (listed as unformatted, and I’m pretty sure not part of the array).  I have the pull down option to list disk 6 as “no device” and can the list the 5TB as the parity.


But I hit a dead end at that point because disk 6 now says it is missing the disk and most options are grayed out. It won’t give me an option the start the array bc it claims I have a missing disk.  The only way to start the array is to put the 5tb parity back to disk 6, and then I can start imthe array as unprotected. 


There have ave been a couple files added to the array in the meantime. Is there any way to reassign the 5tb as parity and restart the array?

Link to comment

If you ever started the array with that disk assigned to slot6 then it is part of the array. Does it think you have a missing parity disk or does it just think you don't have one assigned? Did you start the array at some point with no disk assigned as parity? That is the only way I can see it allowing you to assign your missing parity disk to slot6 unless you New Config.


I guess it doesn't matter now, it is unclear whether that disk would still have valid parity or not. I guess you'll just have to move forward. You are going to have to build parity however you proceed so might as well be to the new 8TB.


Probably not much danger in going ahead without testing it because the rebuild is going to be a bit of a test anyway. And if it fails you are no worse off and can try again with the 5TB and New Config. The only thing it won't do is the "burn-in" that some people like to do with multiple preclears to try to make sure the disk won't suffer "infant mortality".

Link to comment

Thank you. Yes, array was started with the 5TB assigned to disk 6. Oops. Oh well. You are right. Probably best to just proceed with the 8TB as parity.  Any idea how long it will take to rebuild the parity drive?


(4 yr old server running pro-supermicro MBD-X9SCL+ -F-O w/ G1610 Dual Core Ivy Bridge)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.