Jump to content
Sign in to follow this  
maxstevens2

GPU passtrough KVM not working OVMF, works with SeaBios

6 posts in this topic Last Reply

Recommended Posts

In my system i have the following specs:
CPU:FX-8350

RAM:16GB DDR3 @1866

Motherboard: MSI 970 Gaming

GPU#1: Quadro fx1800 (unraid command line)

GPU#2: Quadro fx3800

 

What i am trying to figure out is:
Why do i get a display output when i use SeaBios with my Windows 10 VM, but do i not get this using OVMF?

GPU config:

afbeelding.png.143affa77e3af91c658684a1e0311751.png

I have tried:
Using Custom ROM (https://www.techpowerup.com/vgabios/?did=10DE-05FF-10DE-0661)

rebooting server

 

Does anyone have an idea how i can fix this?
I really need to get OVMF with gou passtrough working because of the XML arguments that i want to use.

Greetings, Max

 

Share this post


Link to post
Posted (edited)

Also something i think might be important to tell: the server itself is on legacy mode. I do not know if changing this will make the server unbootable?

Edited by maxstevens2

Share this post


Link to post

I'm no expert but I think that your GPU / BIOS need to be UEFI compatible to use OVMF. the FX3800 bios you linked to says: UEFI Supported: No

 

Share this post


Link to post
Posted (edited)
5 hours ago, Mex said:

I'm no expert but I think that your GPU / BIOS need to be UEFI compatible to use OVMF. the FX3800 bios you linked to says: UEFI Supported: No

 

Oh, thanks! I have now got 2 GPU's wich i think do have UEFI support:  NVIDIA GT730 and a Readeon 7 240. ill put those in tonight

 

Do i not have to change the bios?

Edited by maxstevens2

Share this post


Link to post

I have a Nvidia Quadro K2000 which I pass through to a Windows 10 VM with OVMF bios and it's working fine. 

 

I have not specified any additional bios in the VM settings. 

Share this post


Link to post

I got it working now! i changed it and it started working right away, altough the resolution is buggy, i've discovered this is because of my cable between the GPU and my monitor (DVI to VGA). I will replace this probably. I am now running with:
GPU#1: Quadro FX1800 (unraid console)

GPU#2: Nvidia GT730 (OVMF GPU)

 

Thanks for the help, i would have never thought about it actually haha
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this