Solved - Headless CLI boot not working on trial?

Recommended Posts

I ave the trial working, but unless I boot the GUI mode, and sign in, it doesn't get and address from DHCP and doesn't mount the arrays or anything.  Is this by design for the trial?  Or is there a setting I'm missing somewhere?


I want to run headless, but having to manually sign in on the console any time I reboot is holding me back from purchasing.

Edited by Abzstrak
Link to comment

Have you tried booting into; GUI mode and then NOT signing in and checking if you are getting an IP address?


just asking as there have been reports that some motherboards only boot with GUI mode option, but that you do not need to login and can still effectively run in headless mode controlling Unraid over the network.

Link to comment

when I don't sign in, no IP.  It doesn't appear to make a DHCP request until after I login.  Obviously this means I cannot access the web console from elsewhere on the LAN unless I login from the gui mode. 


I've switched to another virtual console from the login screen and confirmed.  I can run dhcpcd manually on the bond and get an IP, but that's not really getting me anywhere as it still require manual intervention. This also doesn't mount anything or start nginx.


I must be missing a setting somewhere...



Edited by Abzstrak
Link to comment

I figured it out, in case anyone has similar issues.


Between my Cisco switch and pfsense, somehow dhcpcd was coming up before the port was up on the switch entirely... I found that if I left it for a while at the CLI login (like 7 minutes) it would eventually get the IP and start working... however, at that point, the check was already made for internet access (for the trial) so it wouldn't start the array.


Simply fix, I set a static IP.  I usually don't use these in lieu of DHCP reservations, but it immediately solved the issue, everything works as expected.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.