Jump to content
Sign in to follow this  
Rags

Idle windows VMs max out random CPU core all the time.

6 posts in this topic Last Reply

Recommended Posts

Posted (edited)

I am not sure when this began but yesterday when running some windows updates on some of my Windows VMs, I noticed that when a user is logged into windows (same issue with both windows VMs) and not connected, meaning I RDP'd in and closed the window leaving a user logged into windows, it will peg out one of my cores to max and stay there (seen in my dashboard view). It's not always the same core, it hops around but always pegs one out to 100%. If i reconnect the RDP session, the problem vanishes immediately every single time. But immediately pegs a random core out just seconds after disconnecting. If i boot the VM and never login to windows, it doesnt happen. Anyone have idea on how to trouble shoot this?

 

First thing I thought was some app that I had installed, but my VMs are very slim and dont have much at all installed. From my own troubleshooting it doesnt appear to be related to installed software in the VMs, at least not that I can tell.

 

This is not so bad I know.. but I would like to avoid any needless wear and tear on my hardware. 

 

Any help is appreciated.

 

--Rags

Edited by Rags

Share this post


Link to post

Apparently this is a bug in the latest build of Windows.

Share this post


Link to post

Ahh, good to know. Thank you for the swift response. You or someone you know is experiencing the same issue?

Share this post


Link to post

There have been quite a few reports in the forum, and some of them have reported that the same can happen even on bare metal installs of Windows if you are using RDP.    Should be able to find out more via Google.

Share this post


Link to post
Posted (edited)
14 hours ago, johnnie.black said:

Disabling the policy resolved my issue. Thank you much! Anyone still looking for a fix for this, see below ---

 

Windows 10 1903 introduces a new display driver for remote desktop sessions (WDDM based Indirect Display Driver - IDD). As soon as a rdp session gets disconnected (i.e. the user is still logged in, but the rdp session is disconnected) the new driver causes the Desktop Window Manager (dwm.exe) to max out one cpu core.

 

- Switch off the new driver by disabling the following Group Policy (gpedit.msc) : "Use WDDM graphics display driver for Remote Desktop Connections" in "Computer Configuration\Policies\Windows Settings\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment\"

 

 

--Rags

Edited by Rags

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this