[SOLVED] Can't seem to create Linux VM's


4 posts in this topic Last Reply

Recommended Posts

I'm struggling to create linux VM's.  I've tried a few different images, but all seem to fail out due to networking issues I think.  Ubuntu, Lubuntu, arch.  All fail.  I've created VM's before without an issue, but since I last created a VM I have done the following:

 

Installed Wireguard and Pihole side by side (so changed my server ports)

Installed Letsencrypt

Create a new network for Jitsi.

 

None of these might be related, however maybe I missed something in there?

I've attached the log file for the error I'm getting during the VM creation as well as my server diagnostics.  

Anything I'm doing wrong?

Screenshot 2020-05-11 at 16.35.02.png

Screenshot 2020-05-11 at 16.31.10.png

tower-diagnostics-20200511-1637.zip

Edited by Vannie
Solved
Link to post

it looks to me like you CAN create the VMs and they do boot, but the installs "fail out" when trying to do network access during the installation?
 

If that's the case, sounds like one of your listed changes (probably not Letsenrypt) might be the culprit.

 

Is your Jitsi IP range in the 192.168.86.xx address space seen in the second image?  I'm wondering if your VMs are connecting to the IP range and not finding a DHCP server to give them an IP address.

Link to post

Well, as per Spaceinvaderone's vid, I created a new network for the Jitsi containers.  It should just my my standard router delivering DHCP.

 

I wonder if I should try to put my VM's on their own network, how would I do that?

Link to post

I figured it out! 

So I had this situation where my Samsung TV Plex client wouldn't recognise my Plex server.  Just couldn't figure it out.  The DHCP server automatically assigned an IP address which was fine for about a year.   

DHCP address - 192.168.86.26

But what I didn't think about was that I created a wireguard client that also assigned this IP address as valid in its range. 

And when I tried to create a VM it was also assigning this IP address.

A quick cleanup later and everything works again. 

Link to post
  • JorgeB changed the title to [SOLVED] Can't seem to create Linux VM's

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.