Jump to content
Sign in to follow this  
Pinch

Windows sees virtual machine - code 43

1 post in this topic Last Reply

Recommended Posts

I have been struggling to get gpu passthrough working for some time now, but it just won't work on Unraid.

 

When ESXi is installed on the system, the gf 1070 will pass through fine to a Windows guest, but the same on Unraid will result in code 43 -- the install is a virtual machine.

 

Hyper-V has been set to 'no', but despite of this Windows still clearly states the system is a virtual machine in the task manager*. Nothing's hidden from the guest it seems.

 

The hardware:

Gigabyte Aorus Pro X570 + Asus ROG Strix X570-E Gaming (tried both; same problem)

Ryzen X3950

EVGA 1070

 

I have tried all the xml additions googling help with code 43 will give to no avail.

Since the OS is saying it's a virtual machine, I'm not suprised by the Nvidia drivers being aware too... -- this must be the issue, right?

Booting without a VNC gpu will give a black screen.

ROM has been dumped and set up.

 

 

Does anyone have any idea why Windows won't get fooled? I am fairly desperate at this point.

 

*On the 'Performance' tab. If the system's not virtual, it will state whether it is virtualization-capable or not.

Edited by Pinch

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this