• Unraid 6.90-beta33 or beta35 Parity-Check bug?


    lyqalex
    • Minor

    Unraid 6.90-beta33 or beta35, normally restart or shut down the host twice, and start Parity-Check will run automatically after entering the system, I can only aborted.



    User Feedback

    Recommended Comments

    Then during the shutdown, the system forced a processes that was tying up the system to close.

    Link to comment
    Share on other sites
    16 hours ago, ljm42 said:

    See this post for the various shutdown timeouts that need to be synchronized: 

     

    I have very few docker and vms, which are openwrt, plex and dsm. I need to shut them down before shutting down or restarting unraid, otherwise the waiting time will be long. So I think it is a system bug.

    Link to comment
    Share on other sites

    These are configurable settings. If the defaults don't work for you, then you need to set them up for your particular system:

     

    • "Settings->VM Manager->VM Shutdown time-out": must be long enough to allow your VMs to shutdown
    • "Settings->Disk Settings->Shutdown time-out": must be long enough for the array to stop *after* VMs have shutdown. So 60 to 120 seconds longer than the VM timeout.

     

    If a parity check starts after shutting down, then you Disk Settings->Shutdown time-out setting is too short for your particular system.

     

    If you would like more of an explanation, see this post (which is embedded in the post I linked to above):

     

    Link to comment
    Share on other sites
    12 hours ago, ljm42 said:

    These are configurable settings. If the defaults don't work for you, then you need to set them up for your particular system:

     

    • "Settings->VM Manager->VM Shutdown time-out": must be long enough to allow your VMs to shutdown
    • "Settings->Disk Settings->Shutdown time-out": must be long enough for the array to stop *after* VMs have shutdown. So 60 to 120 seconds longer than the VM timeout.

     

    If a parity check starts after shutting down, then you Disk Settings->Shutdown time-out setting is too short for your particular system.

     

    If you would like more of an explanation, see this post (which is embedded in the post I linked to above):

     

    thank you. I will try.

    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.