Jump to content
  • Unraid OS version 6.12.3-rc3 available


    The 6.12.3-rc3 release is a bug fix release that we'd like feedback on before releasing it as 6.12.3.


    This thread is perfect for quick questions or comments, but if you suspect there will be back and forth for your specific issue, please start a new topic. Be sure to include your diagnostics.zip.


    Upgrade steps for this release

    1. As always, prior to upgrading, create a backup of your USB flash device:  "Main/Flash/Flash Device Settings" - click "Flash Backup".
    2. Update all of your plugins. This is critical for the NVIDIA and Realtek plugins in particular.
    3. If the system is currently running 6.12.0 - 6.12.2, we're going to suggest that you stop the array at this point. If it gets stuck on "Retry unmounting shares", open a web terminal and type:
      umount /var/lib/docker

      The array should now stop successfully (This issue is resolved with this release)

    4. Go to Tools -> Update OS, change the Branch to "Next". If the update doesn't show, click "Check for Updates"
    5. Wait for the update to download and install
    6. If you have any plugins that install drivers (NVIDIA, Realtek, etc), wait for the notification that the new version of the driver has been downloaded. 
    7. Reboot




    This release has fixes for networking, particularly as it relates to IPv6. A side effect is that this will resolve an issue where the webgui won't load in certain instances. 


    Note: If you have code in your go script to disable IPv6, remove that and disable it via the Settings -> Network Settings page instead. Disabling IPv6 by manually running commands will cause conflicts.



    This release resolves an issue where Docker doesn't properly stop when the array stops, which can result in an unclean shutdown. 


    Known Issues


    Please review the known issues for 6.12: https://docs.unraid.net/unraid-os/release-notes/6.12.0#known-issues 


    If Docker containers have issues starting after a while, and you are running Plex, go to your Plex Docker container settings, switch to advanced view, and add this to the Extra Params


    Feedback / bugs


    This thread is perfect for quick questions or comments, but if you suspect there will be back and forth for your specific issue, please start a new topic. Be sure to include your diagnostics.zip.

    Changes vs. 6.12.2


    Bug fixes and improvements

    • rc.docker: revised docker daemon running check
    • rc.library:
      • code optimization for ipv6 max/min
      • support ipv4 mapped addresses
    • rc.nginx: explicit ipv4/ipv6 selection on lo interface
    • shfs: correct share size calculation when zfs is one of the volumes
    • webgui: VM settings page: fixed typo
    • webgui: Share Edit page: make minimum free space settings always available


    Linux kernel

    Added support to monitor and also limit power on Intel Core (2nd Gen+) CPU models.

    • version 6.1.38
      • CONFIG_POWERCAP: Generic powercap sysfs driver
      • CONFIG_INTEL_RAPL: Intel RAPL Support via MSR Interface
      • CONFIG_IDLE_INJECT: Idle injection framework


    Base Distro

    • firefox: version 115.0.r20230710165010 (AppImage)
    • Like 10
    • Thanks 1

    User Feedback

    Recommended Comments

    Array is stopping correctly with this release and I did not detect any problem, I have also enabled IPv6 just to test it (although I don't enable IPv6 on my servers by default) and webgui loads correctly.


    Two issues (which are not mentioned to be fixed) are still there:


    So currently at least for me Docker is not useable yet.

    Link to comment
    31 minutes ago, thecode said:

    Two issues (which are not mentioned to be fixed) are still there:


    The first one is macvlan, our best solution for macvlan issues at this point is mentioned in the 6.12.0 release notes:


    I know some folks aren't happy with that solution, believe me if we get something better we will not forget to put it in the release notes : )


    The second post is a mix of topics that is really hard to follow. In general, I would expect networking to be better with this RC. If there are still issues we need new diagnostics showing the issue.

    • Like 1
    Link to comment

    Thanks everyone for the help testing. These fixes, plus a few more related to networking, are now available in Unraid 6.12.3: 


    We encourage everyone to upgrade


    • Like 1
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...