Jump to content
  • 6.12.2 modified my network settings, making web access impossible

    • Solved Minor

    I have a super micro X8sie-LN4 motherboard with four lan ports. I had Unraid set to use only the first port, pretty standard settings. After the update I couldn't log in to the server remotely and no dockers responded via web. Logging in on the physical monitor, I saw the network settings did not list all four lan ports as it used to, and my primary lan port had been changed to a bonded connection and had no mac address. I tried deleting the network configuration file and setting the primary lan port up as I had it, as a non-bonded static IP with a bridge, and then using DHCP, but nothing worked. I had to revert to 6.11.5, where everything worked as normal again.

    I don't have logs or diagnostics, but I did tell the server to save them before the downgrade; maybe they're on the server and accessible to me?

    User Feedback

    Recommended Comments

    All NICs are failing to initialize with the same error, most likely some kernel/driver incompatibility:


    Jul 10 16:47:58 Unraid kernel: e1000e 0000:06:00.0: Unable to change power state from D3cold to D0, device inaccessible
    Jul 10 16:47:58 Unraid kernel: e1000e 0000:06:00.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
    Jul 10 16:47:58 Unraid kernel: e1000e 0000:06:00.0 0000:06:00.0 (uninitialized): Failed to initialize MSI-X interrupts.  Falling back to MSI interrupts.
    Jul 10 16:47:58 Unraid kernel: e1000e 0000:06:00.0 0000:06:00.0 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
    Jul 10 16:47:58 Unraid kernel: e1000e: probe of 0000:06:00.0 failed with error -2


    • Upvote 1
    Link to comment

    Is there anything I can do? I assume the drivers are part of the Unraid software and not something I can update via motherboard BIOS?

    Link to comment
    2 minutes ago, ZERØ said:

    Is there anything I can do?

    Likely not much, suggest trying a future new Unraid release, with a newer kernel, hopefully it will start working the same way it stopped.

    • Upvote 1
    Link to comment

    Ok, thanks for the help, I'll wait for a new release and try again. At least now I know the issue and won't spend much time troubleshooting if it happens again.

    Link to comment

    Forgot to mention that a BIOS update and/or CMOS reset may also be worth trying, IIRC a user with a similar issue fixed it by moving the NIC to a different PCIe slot, you cannot do that but a BIOS change could make a difference.

    Link to comment

    6.12 combined all my NICs into one NIC. It would sometimes work, sometimes it wouldn't be assigned a mac address. I updated the motherboard bios from 1.2 to 1.2a and now I see all four NICs again.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...