Jump to content
  • Array does not autostart in 6.11.5! Serious issue!

    • Closed

    After server reboot, the array does not autostart!

    It is set to auto-start in settings/disk settings.

    Array has no issue, pressing to start it, starts it fine (no parity re-check or anything).

    This is very important because someone has to login the server either from its own console or using IP (and not FQDN as DNS etc. are in containers and VMs) to just press "start array"!

    Array worked fine (and auto-started) for years.


    User Feedback

    Recommended Comments

    Well obviously something is wrong...

    (I now set it to "no", saved and then back to "yes" and saved again in case something got "stuck"?)




    EDIT: Tried the above and rebooted.
    AGAIN server started with the array offline and just needed me to click "start array". :(
    This is weird and serious.


    One change I did a couple of days ago was this. I edited my syslinux config (using UNRAID GUI), and modified two entries:


    label Unraid OS
      kernel /bzimage
      append initrd=/bzroot nvme_core.default_ps_max_latency_us=0
    label Unraid OS GUI Mode
      menu default
      kernel /bzimage
      append initrd=/bzroot,/bzroot-gui nvme_core.default_ps_max_latency_us=0

    ...because of a firmware issue with my M.2 cache.

    (I added nvme_core.default_ps_max_latency_us=0)


    But I don't see how this could be related...



    Cancel the above edit. The "turn setting off and then on and reboot" actually fixed the hiccup.

    The problem right above was because some disk cable was needed reseating.


    In less words:

    System somehow mixed up the array auto start setting, after my last updates and edits.

    It displayed "auto start yes" but did not autostart.

    I switched to "auto start no", "apply", then back to "auto start yes" and "apply" and this seems to have reset the setting fine.


    Edited by NLS
    Link to comment

    Array didn't auto-start because disk4 was initially missing


    Nov 28 23:37:25 quasar-ultima kernel: mdcmd (5): import 4
    Nov 28 23:37:25 quasar-ultima kernel: md: import_slot: 4 missing


    It came back online a few seconds later, that's why you could then start the array manually:


    Nov 28 23:37:45 quasar-ultima kernel: mdcmd (5): import 4 sdm 64 3907018532 0 WDC_WD40EFAX-68JH4N1_WD-WX42D410YUKV
    Nov 28 23:37:45 quasar-ultima kernel: md: import disk4: (sdm) WDC_WD40EFAX-68JH4N1_WD-WX42D410YUKV size: 3907018532


    So it's not an Unraid problem, check/replace cables on that disk.


    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...