Jump to content
  • ZFS Dataset not created when share is set to cache only

    • Annoyance

    From my understanding, a dataset should be automatically created if a share is set to cache only, and the cache is zfs.


    I have created (manually) datasets for each of my appdata, isos, system, and domains shares. I used rsync to move the data from the folders into the datasets.


    I create a new share called Test and set it to cache only. A new dataset appears called "Test". However, if an existing share is set to cache only and the data is moved to the cache, a dataset is not created and the manual process must be followed to create a dataset and transfers the data into one. Is this the intended behaviour? 



    User Feedback

    Recommended Comments

    If I'm understanding the issue correctly I cannot reproduce, I've created a new share on an XFS array drive, then set the share to be moved to a zfs pool, ran the mover, a new dataset was created for the share on the zfs pool.

    Link to comment

    i have same issue for , domains and system folders ... 

    all them is exlusive acces ... but only appdata is avalible like dataset






    Link to comment

    I have the same issue. I would like to know if this is expected behavior or not. I think this has been causing some issues with some of my dockers. 

    @JorgeB - I think to replicate this, don't use mover (perhaps this is where we are making a mistake). For the OP, rsync was used. For me, I had used Dynamix File Manager. 

    1 - Share exists on XFS cache pool
    2 - Used DFM to move from cache pool to array

    3 - Formatted old cache pool to ZFS

    4 - Used DFM to move the files to the new ZFS pool


    Link to comment
    18 minutes ago, Indi said:

    I had used Dynamix File Manager. 

    It should create a dataset if you use user shares, it won't create one if you use disk shares, e.g., move from /mnt/pool1 to /mnt/pool2

    Link to comment
    5 minutes ago, JorgeB said:

    it won't create one if you use disk shares

    This is it, I had done /mnt/disk8 to /mnt/cache_system 

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...