andre (buanet)

Members
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

4 Neutral

About andre (buanet)

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. @mgutt Ja, es wäre kein Problem den EXPOSE mit auf zu nehmen, allerdings hatte ich das im Image eigentlich absichtlich weg gelassen, da das der ENV "ADMINPORT" zum anpassen des default Admin Ports widerspricht. Außerdem wechseln die meisten User sowieso über kurz oder lang zum Network HOST oder MACVLAN weil es eine Reihe Adapter gibt die im Bridge Netzwerk einfach nicht laufen (können). Falls das in Bezug auf Unraid ein wichtiger Punkt sein sollte, dann bitte einen entsprechenden Issue erstellen damit wir das in der Community mal besprechen können. Was das ioBroker Template angeht
  2. Das ist ein Fall fürs ioBroker Forum. In deinem Auszug ist wieder ein File exists: /opt/iobroker/node_modules/.bin/tsservernpm ERR! Remove the existing file and try again, or run npmnpm ERR! with --force to overwrite files recklessly drin. Gleiches Thema wie beim js-controller. Du kannst die Konflikte entweder händisch lösen oder per "iobroker backup" deine Daten sichern und in einem neuen Container restoren (habe ich auch was zu auf der seite). Das braucht zwar etwas Zeit, ist aber die beste Lösung um wieder ein sauberes und updatefähiges System zu erhalten. Bei diesem Schritt we
  3. Da bin ich jetzt nicht der Profi. Das ist ein NPM Thema. Da ich davon ausgehe dass du dein ioBroker Verzeichnis einmal gesichert hast, würde ich versuchen dem nach zu kommen und das angemeckerte file plump löschen und es nochmal versuchen. Sollte das nicht funktionieren findest du so gut wie jede npm Fehlermeldung irgendwo im ioBroker Forum. MfG, André
  4. Ok. Also die Console über Unraid geht schonmal nicht, weil er die Verbindung mit "Shell" und nicht "Bash" aufbaut. Das kannst du ändern in dem du den Container editierst und das hier umstellst: Die Meldung die du im Portainer bekommst habe ich schonmal gehabt, und zwar hier: https://github.com/buanet/ioBroker.docker/issues/167 Lösung war dann dies: Vermutlich war die Ursache, dass die betreffende ioBroker Instanz irgendwann mal zu Docker migriert wurde. Weiß nicht ob das bei dir auch der Fall war. In jedem Fall solltest du das File "iobroker" (in
  5. Das sieht schon mal gut aus. Du bist auf dem richtigen Weg. Allerdings hast du da jetzt eine andere Fehlermeldung. Nix mit iobroker not found... Die Meldung die du da hast hab ich schonmal irgendwo gesehen. Ich schau mal nachher was ich finde, wenn ich am PC bin... MfG, André
  6. Sorry, zu wenig Details. Bevor wir hier lange rum machen, hast du nen Screenshot von deinem Konsolenfenster im Portainer und dem Befehl? Kannst du auf der Konsole irgend etwas machen? z.B. top oder ping? MfG André
  7. Wieso brauchst du denn noch ne idee? Die Kommandozeile ist der weg wie man den js-controller updated. Bist du dir sicher dass du auf der Kommandozeile innerhalb des Containers bist? Du musst dich natürlich erst dorthin verbinden. Lies dich mal zu "docker exec" schlau. Dein output lässt mich vermuten, dass Du lediglich auf der Kommandozeile vom unraid unterwegs warst, und der kennt nunmal kein iobroker... MfG, André
  8. Auf der Kommandozeile im Container... und dann so wie hier: https://smarthome.buanet.de/2020/10/iobroker-docker-container-updates-upgrades/
  9. Just in case someone comes along this thread like I did today ... I'm on 6.9 and ran into a similar issue when trying to replace an image by changing the path in the xml template. Deleting container, Path changing, reloading, nothing helped. I ended up deleting the image at "/var/lib/docker/unraid/images/". When then building a new container from the template the image was pulled again and the new image appears! Regards, André
  10. Thanks for your quick response. You are absolutely right. It was the branch. After Githubs change, to generally rename the master branch to main it might be useful to place this as an issue. But where?
  11. Hi, I'm quite new to Unraid and trying to get in touch with Unraids Docker XML templates. I created a simple Github repo. Then created a XML template using the "Template Authoring Mode" in Unraid and pushed the file to the repo. After all i added my repo to the "Template repositories:" Section in the Docker tab. When I'm now trying to add a new container there is no template displayed in the dropdown menu. I tested with some other repos like https://github.com/juusujanar/unraid-templates which worked well. Im quite not sure what else is needed to make my