ctietze

Members
  • Posts

    1
  • Joined

  • Last visited

Everything posted by ctietze

  1. I have trouble making outgoing connections from inside the Docker proxy net (not using the Unraid bridge). curl -I google.com works curl -I some.dyndns.for.same.lan fails (e.g. cloudpi.dns.navy, a test device on a Raspberry Pi) curl -I -x swag:80 some.dyndns.for.same.lan works E.g. when I open the console for the SWAG container and try to access a Raspberry Pi that's connected to the web: # curl -Iv cloudpi.dns.navy * Trying 37.201.145.221:80... * Trying 2a02:908:4b60:a2e0:ba27:ebff:fe83:4fe:80... * Immediate connect fail for 2a02:908:4b60:a2e0:ba27:ebff:fe83:4fe: Address not available * Trying 2a02:908:4b60:a2e0:ba27:ebff:fe83:4fe:80... * Immediate connect fail for 2a02:908:4b60:a2e0:ba27:ebff:fe83:4fe: Address not available This is puzzling me a lot. If you copy and paste the CURL command, you'll notice that this will work fine from a regular computer. (Maybe even from your own Unraid SWAG instance? Dunno) If I define a proxy parameter in the request, this works out better: # curl -I -x swag:80 cloudpi.dns.navy HTTP/1.1 301 Moved Permanently Server: nginx/1.18.0 Date: Fri, 22 Jan 2021 11:10:48 GMT Content-Type: text/html Content-Length: 169 Connection: keep-alive Location: https://cloudpi.dns.navy/ The same -x parameter makes the CURL request reach the destination device from my SWAG container and my Nextcloud container. I can't get it to work with a https:// URL when I specify swag:443 as the proxy. I get a 400 Bad Request by SWAG. Same for -x swag:443 https://google.com, so the port 443 forwarding isn't limited to my DynDNS. I went down the CURL rabbit hole because my Nextcloud could connect to an instance I hosted on my web server, but not to the device with the dns.navy URL (it is in the same LAN). I don't know anybody with a DynDNS Nextcloud instance to try to figure out what may be going wrong. Am I holding it wrong? Is there any other debugging tool for this I could use? nslookup works, ping works, curl doesn't -- and to that extend connecting Nextcloud instances here don't work either.