-
[Plugin] Tailscale
I'm very sorry for what I know is probably a rather basic question, but I need a little help here please... I have Tailscale on my unraid server, and all appears to be working well. I can access my shares via Tailnet IP, no problem. What I'd like to be able to do, is access another physical machine on the same LAN as the server, through TS, from a remote PC. Is this super basic, complex, impossible? If it matters, the device I want to access is my pfsense router/firewall. Its IP is 162.168.10.1 My server is 192.168.10.10 Can anyone tell me what settings I need to change, and where, to make the pfsense accessible remotely? I kinda thought I had done this on my home tailnet using the "Allow Tailscale Subnets" switch, but maybe not.
-
Remote logging from pfsense router?
Right? Sometimes these things just do what they want. ;) Thanks again for your help. Thread SOLVED. Now my next task is figuring out how to access the pfsense GUI over tailscale, so I can admin it remotely... I never ends. lol
-
Remote logging from pfsense router?
WHOA, hang on. Files just popped in! I have no idea why they took so long to appear, since the firewall has been logging traffic all this time. Is there some sort of "write interval" that's applied? How often does it update? In any case, it appears to be working. :D
-
Remote logging from pfsense router?
-
Remote logging from pfsense router?
-
Remote logging from pfsense router?
This is absolutely amazing, and exactly what I was hoping for, THANK YOU! Just one little hiccup... it doesn't seem to be working. lol I followed all the steps (I think), and it all looks fine, except that no log files are being created on the server in my new share. What can I provide to help diagnose?
-
Remote logging from pfsense router?
My company is being required to retain firewall logs for 1 year, so I figured the easiest route would be remote logging to the unraid server. I've read a ton of how-to's and guides that all claim it's a fairly simple process. Either it's not, or I'm just dumb. My bet is the latter. ;) So far, I have syslog-ng installed and (I think) running on the server. I've configured the pfsense box to enable remote logging, and have pointed it at the syslog-ng IP:port. I also tried setting up a docker for Graylog, but I don't think it's working. At least I can't get to any sort of webGUI for it, and don't know what else I'm supposed to do with it. Can someone please provide (or point me to) a super simple setup guide for how to do remote logging? I just want the pfsense box to dump its logs onto a folder on the server. That's it. It can do it forever, and I'll manually manage them, if I have to. Of course any fancy GUIs or management tools would just be bonus. Diagnostics attached, in case they are of any use. aeserver-diagnostics-20260831-1942.zip
-
Elmojo started following Remote logging from pfsense router?
-
cache pool errors - failing drive or ??
Update/resolution: Samsung replaced my faulty SSD under warranty. After replacing the drive, and moving my VMs and dockers back onto the cache, the machine is now fully back up and running. Thanks to everyone for the help! Issue resolved.
-
VM Backup Plugin
I feel like in the event of a total server meltdown, VM backups are the least of your issues, but fair enough. To be clear, I agree that backups are a good thing to have. I'm using URBackup, and I just used it 2 days ago to recover a failed VM that didn't survive a cache migration. I just wanted you to flesh out your claim a bit. I think a combination of snapshots and backups are even better, but for most people, snapshots alone are enough.
-
VM Backup Plugin
Give me an example of how they are different, in practical terms.
-
VM Backup Plugin
It is. Snapshots have been a thing for the past couple releases. You do read the changelogs, don't you?
-
cache pool errors - failing drive or ??
I was able to fix the VM issue myself by restoring the image from a backup. I guess now I just need to pull the old (failing) cache drive and send it in for repair or replacement, then reverse the process once I receive the new one. I'll try to remember to update once that's done, in case any else runs into a similar issue in the future.
-
cache pool errors - failing drive or ??
root@Tower:~# ls -lah /mnt/cache total 16K drwxrwxrwx 1 nobody users 0 Jun 9 14:55 ./ drwxr-xr-x 17 root root 340 Jun 9 16:00 ../ Gotcha. I figured there would be updates once 7.x was released. So this just leaves the issue of why I have (at least) one VM that didn't migrate. As best I can tell, it didn't pick up the new location of the disk image. I pointed it to the existing image in the new location (array), but now it says no boot device found, or similar. Is there any way to recover it? I sure hope so... EDIT: I recovered the VM using a URBackup image.
-
cache pool errors - failing drive or ??
That link looks to be out of date, since as far as I can tell, there is no "prefer cache" option any longer. At least I haven't seen it. I've looked through all my docker settings, and as best as I can tell, they're all looking at /mnt/user/ not /mnt/cache, with the exception of one (Rustdesk, which I fixed). So why are all the container appdata folders getting recreated when the docker service restarts? It's baffling. Ok, I think I have it cleaned up. It appears that overnight the server sorted it self out and only the Rustdesk files were left on the cache this morning. I deleted those manually, so now there's nothing showing on the cache drive, although it does report that 537MB are in use. I assume that's just overhead, or are there hidden files I should be hunting down?
-
cache pool errors - failing drive or ??
Well that sucks. Also, my VMs (some of them) are broken now. The disk image can't be read in the new location (array) so the machine won't boot. I have no idea what to do about this. One of these VMs runs my security cameras, so it's fairly urgent to get it running again...
Elmojo
Members
-
Joined
-
Last visited