Jump to content

thejamkel

Members
  • Content Count

    46
  • Joined

  • Last visited

Community Reputation

0 Neutral

About thejamkel

  • Rank
    Advanced Member
  • Birthday 07/27/2988

Converted

  • Gender
    Male
  • URL
    http://www.thejamkel.co.uk
  • Location
    Lincolnshire, UK
  • Personal Text
    Newbie Data hoarder!
  1. thejamkel

    [Support] binhex - Airsonic

    I found this post too late! Is it possible to download the previous image?
  2. thejamkel

    [Support] binhex - DelugeVPN

    Awesome. Thank you for taking a look. I will switch off BT protect (I didnt know it was enabled). The desktop PIA client was working so i missed reading into that. Thanks again. On a side note will you be publishing an NZBget vpn docker? I tend to use your dockers as they are always reliable. -James
  3. thejamkel

    [Support] binhex - DelugeVPN

    Hi, I have ensured I applied the IPtables config then rebooted the server. Reinstalled the docker with debug set to true. At the current time in the appdata directory only openvpn seems to be present. I do not see any Deluge related files. Log file below: I waited 10 minutes before taking a paste. https://hastebin.com/qowokequxi.scala Thanks so much for taking the time. -James
  4. thejamkel

    [Support] binhex - DelugeVPN

    Hi there, Thank you for the response. I've read through the FAQ and believe i have done everything correctly. I'm not sure what to do next. -James
  5. thejamkel

    [Support] binhex - DelugeVPN

    Hello, I've just installed this docker (I'm not an advanced docker user). I have reviewed various articles/videos and believe that I've set it up correctly. Could someone take a look at the log below? (I've replaced my username and password with xxx). Created by... ___. .__ .__ \_ |__ |__| ____ | |__ ____ ___ ___ | __ \| |/ \| | \_/ __ \\ \/ / | \_\ \ | | \ Y \ ___/ > < |___ /__|___| /___| /\___ >__/\_ \ \/ \/ \/ \/ \/ https://hub.docker.com/u/binhex/ 2017-05-31 20:53:52.005419 [info] Host is running unRAID 2017-05-31 20:53:52.041658 [info] System information Linux 08b4d2999eb0 4.9.30-unRAID #1 SMP PREEMPT Fri May 26 13:56:36 PDT 2017 x86_64 GNU/Linux 2017-05-31 20:53:52.088792 [info] PUID defined as '99' 2017-05-31 20:53:52.127630 [info] PGID defined as '100' 2017-05-31 20:53:52.172138 [info] UMASK defined as '000' 2017-05-31 20:53:52.217192 [info] Permissions already set for volume mappings 2017-05-31 20:53:52.261187 [info] VPN_ENABLED defined as 'yes' 2017-05-31 20:53:52.301476 [info] VPN_PROV defined as 'pia' 2017-05-31 20:53:52.345228 [info] VPN_REMOTE defined as 'nl.privateinternetaccess.com' 2017-05-31 20:53:52.383023 [info] VPN_PORT defined as '1198' 2017-05-31 20:53:52.427223 [info] VPN_PROTOCOL defined as 'udp' 2017-05-31 20:53:52.467936 [info] LAN_NETWORK defined as '192.168.1.0/24' 2017-05-31 20:53:52.512362 [info] NAME_SERVERS defined as '8.8.8.8,37.235.1.174,8.8.4.4,37.235.1.177' 2017-05-31 20:53:52.554658 [info] VPN_USER defined as 'xxx' 2017-05-31 20:53:52.593504 [info] VPN_PASS defined as 'xxx' 2017-05-31 20:53:52.629806 [info] VPN_DEVICE_TYPE defined as 'tun' 2017-05-31 20:53:52.669655 [info] VPN_OPTIONS not defined (via -e VPN_OPTIONS) 2017-05-31 20:53:52.717715 [info] STRONG_CERTS defined as 'no' 2017-05-31 20:53:52.759200 [info] ENABLE_PRIVOXY defined as 'no' 2017-05-31 20:53:52.794935 [info] Setting permissions on files/folders inside container... 2017-05-31 20:53:53,257 CRIT Set uid to user 0 2017-05-31 20:53:53,257 INFO Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing 2017-05-31 20:53:53,260 INFO supervisord started with pid 6 2017-05-31 20:53:54,261 INFO spawned: 'start-script' with pid 111 2017-05-31 20:53:54,262 INFO spawned: 'deluge-script' with pid 112 2017-05-31 20:53:54,264 INFO spawned: 'deluge-web-script' with pid 113 2017-05-31 20:53:54,265 INFO spawned: 'privoxy-script' with pid 114 2017-05-31 20:53:54,271 DEBG 'start-script' stdout output: [info] VPN is enabled, beginning configuration of VPN 2017-05-31 20:53:54,271 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs) 2017-05-31 20:53:54,271 INFO success: deluge-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs) 2017-05-31 20:53:54,271 INFO success: deluge-web-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs) 2017-05-31 20:53:54,271 INFO success: privoxy-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs) 2017-05-31 20:53:54,273 DEBG 'deluge-script' stdout output: [info] Deluge config file already exists, skipping copy 2017-05-31 20:53:54,274 DEBG 'deluge-script' stdout output: [info] VPN is enabled, checking VPN tunnel local ip is valid 2017-05-31 20:53:54,276 DEBG 'privoxy-script' stdout output: [info] Privoxy set to disabled 2017-05-31 20:53:54,277 DEBG fd 26 closed, stopped monitoring <POutputDispatcher at 47035645370024 for <Subprocess at 47035644270208 with name privoxy-script in state RUNNING> (stderr)> 2017-05-31 20:53:54,278 DEBG fd 22 closed, stopped monitoring <POutputDispatcher at 47035644203088 for <Subprocess at 47035644270208 with name privoxy-script in state RUNNING> (stdout)> 2017-05-31 20:53:54,278 DEBG 'start-script' stdout output: [info] VPN default certs defined, copying to /config/openvpn/... 2017-05-31 20:53:54,279 INFO exited: privoxy-script (exit status 0; expected) 2017-05-31 20:53:54,280 DEBG received SIGCLD indicating a child quit 2017-05-31 20:53:54,280 DEBG 'start-script' stdout output: [info] VPN config file (ovpn extension) is located at /config/openvpn/openvpn.ovpn 2017-05-31 20:53:54,286 DEBG 'start-script' stderr output: dos2unix: converting file /config/openvpn/openvpn.ovpn to Unix format... 2017-05-31 20:53:54,335 DEBG 'start-script' stdout output: [info] Default route for container is 172.17.0.1 2017-05-31 20:53:54,337 DEBG 'start-script' stdout output: [info] Adding 8.8.8.8 to /etc/resolv.conf 2017-05-31 20:53:54,341 DEBG 'start-script' stdout output: [info] Adding 37.235.1.174 to /etc/resolv.conf 2017-05-31 20:53:54,347 DEBG 'start-script' stdout output: [info] Adding 8.8.4.4 to /etc/resolv.conf 2017-05-31 20:53:54,352 DEBG 'start-script' stdout output: [info] Adding 37.235.1.177 to /etc/resolv.conf 2017-05-31 20:53:54,360 DEBG 'start-script' stdout output: [info] Adding 192.168.1.0/24 as route via docker eth0 2017-05-31 20:53:54,361 DEBG 'start-script' stdout output: [info] ip route defined as follows... -------------------- 2017-05-31 20:53:54,362 DEBG 'start-script' stdout output: default via 172.17.0.1 dev eth0 172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.5 192.168.1.0/24 via 172.17.0.1 dev eth0 2017-05-31 20:53:54,362 DEBG 'start-script' stdout output: -------------------- 2017-05-31 20:53:54,366 DEBG 'start-script' stdout output: [info] iptable_mangle support detected, adding fwmark for tables 2017-05-31 20:53:54,418 DEBG 'start-script' stdout output: [info] Docker network defined as 172.17.0.0/16 2017-05-31 20:53:54,478 DEBG 'start-script' stdout output: [info] iptables defined as follows... -------------------- 2017-05-31 20:53:54,480 DEBG 'start-script' stdout output: -P INPUT DROP -P FORWARD ACCEPT -P OUTPUT DROP -A INPUT -i tun0 -j ACCEPT -A INPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT -A INPUT -i eth0 -p udp -m udp --sport 1198 -j ACCEPT -A INPUT -i eth0 -p tcp -m tcp --dport 8112 -j ACCEPT -A INPUT -i eth0 -p tcp -m tcp --sport 8112 -j ACCEPT -A INPUT -s 192.168.1.0/24 -i eth0 -p tcp -m tcp --dport 58846 -j ACCEPT -A INPUT -p udp -m udp --sport 53 -j ACCEPT -A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT -A INPUT -i lo -j ACCEPT -A OUTPUT -o tun0 -j ACCEPT -A OUTPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT -A OUTPUT -o eth0 -p udp -m udp --dport 1198 -j ACCEPT -A OUTPUT -o eth0 -p tcp -m tcp --dport 8112 -j ACCEPT -A OUTPUT -o eth0 -p tcp -m tcp --sport 8112 -j ACCEPT -A OUTPUT -d 192.168.1.0/24 -o eth0 -p tcp -m tcp --sport 58846 -j ACCEPT -A OUTPUT -p udp -m udp --dport 53 -j ACCEPT -A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT -A OUTPUT -o lo -j ACCEPT 2017-05-31 20:53:54,481 DEBG 'start-script' stdout output: -------------------- 2017-05-31 20:53:54,481 DEBG 'start-script' stdout output: [info] Starting OpenVPN... 2017-05-31 20:53:54,488 DEBG 'start-script' stdout output: [info] OpenVPN started Any help would be much appreciated. If required my local IP is: 192.168.1.x and it appears the CIDR is correct. The WebUI appears to not load despite triple checking credentials. Thanks!
  6. thejamkel

    Server Crashing

    Thanks for the replies. I believe the motherboard has the latest firmware revision, but I will double check. I will run a mem test over the weekend. Thanks again.
  7. thejamkel

    Server Crashing

    Hello, My server appears to be crashing and I'm unsure of the cause. I don't have a monitor i can connect to the server easily but i have collected logs via the fix common problems plugin in troubleshooting mode. I have attached those files to the thread. These logs are inclusive of the latest release of unRaid (it has been happening randomly for 6 months but more so frequently at the moment). I would appreciate any help/information on what to look for within the logs so I can troubleshoot more on my own before having to reach out. I have a feeling there could be an issue with my cache drive and it is on the list to replace (Mechanical at the moment will be moving to SSD soon). Thank you so much in advance! James Logs.zip
  8. thejamkel

    Server Crashing

    Thank you Squid, it is running now. I will report back with logs.
  9. thejamkel

    Server Crashing

    Hello there, It's been a while since I've had to do anything with my server as it's just been ticking away and playing nice. However I seem to be encountering times (quite frequently at the moment) where the server will just not respond (No pings, Telnet or web interface) I dont have a monitor I can easily attach at the time where it is down either. To fix it I simply reboot but of course this means I need a new parity check each time and shouldnt really be happening. Could someone point me the right direction of the logs I should be collecting or additional logging I should be enabling? Thanks so much in advance. James
  10. thejamkel

    ControlR (Android/iOS app for unRAID)

    Hi there sorry for the delay in getting back to you. I have upgraded to the latest version but without a password I have the problem. I set a password and the issue has now gone. I must note that the checkboxes after i log in do not save and i see no submit button. Appreciate your help.
  11. thejamkel

    ControlR (Android/iOS app for unRAID)

    Hi there, Sorry for the delay. The page loads but when i try to login it says unable to connect to server. 401 unauthorised. I've not bothered as my server is in my home adding a password to the default root user could this be the cause? -J
  12. thejamkel

    ControlR (Android/iOS app for unRAID)

    Hey there, been using your app a log time. I noticed the logs section required a plugin to work. I've installed and enabled the plugin however I still don't seem to be able to get any logs shown (Android device). Any ideas?
  13. thejamkel

    Docker starts then crashes my server

    Checked logs myself found xfs was corrupt had to run xfs_repair -L trying to see how much data is lost. Thanks alot for getting me in the right direction!
  14. thejamkel

    Docker starts then crashes my server

    My array has been failing to start. I have now downgraded to 6.1.9 and see seem to have the same issue with the array not starting. I appear to be stuck on mounting disks. Can you offer any advise?