Jump to content

Stinkpickle

Members
  • Content Count

    25
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Stinkpickle

  • Rank
    Member

Converted

  • Gender
    Undisclosed
  1. I am not sure if the current cleanup script is deleting the proper check file. This is the cleanup script I have, #!/bin/bash ####################### ### Cleanup Script #### ####################### #### Version 0.9.1 #### ####################### echo "$(date "+%d.%m.%Y %T") INFO: *** Starting rclone_cleanup script ***" ####### Cleanup Tracking Files ####### echo "$(date "+%d.%m.%Y %T") INFO: *** Removing Tracking Files ***" find /mnt/user/appdata/other/rclone/remotes -name dockers_started -delete find /mnt/user/appdata/other/rclone/remotes -name mount_running -delete find /mnt/user/appdata/other/rclone/remotes -name upload_running -delete echo "$(date "+%d.%m.%Y %T") INFO: ***Finished Cleanup! ***" exit And it appears the upload check file is called "/mnt/user/appdata/other/rclone/remotes/%remotename%/upload_running_daily_upload", that has held up my upload script from running previously. Just a thought.
  2. Thank you, this got me going. Do you happen to know why none of this traffic shows on the beta rclone webui? Was looking for a way to track transfer progress.
  3. My concern was the "sgdrive_media" folder residing in the localshare folder, would the script not be looking at /mnt/user/Media/sgdrive_media?
  4. I am looking for a clean way to migrate my Movie collection without causing issues. I don't have enough free space on my array to duplicate my Movie directory into the google drive mergefs share. I was going to point my Local directory for these scripts to my current Media share on Unraid, would that be an ok way to upload my files without moving them? I noticed the currently directory structure gets kind of embedded twice with the RcloneRemoteName. My current mount/upload scripts look like this; #!/bin/bash ###################### #### Mount Script #### ###################### ### Version 0.96.6 ### ###################### ####### EDIT ONLY THESE SETTINGS ####### # INSTRUCTIONS # 1. Change the name of the rclone remote and shares to match your setup # 2. NOTE: enter RcloneRemoteName WITHOUT ':' # 3. Optional: include custom command and bind mount settings # 4. Optional: include extra folders in mergerfs mount # REQUIRED SETTINGS RcloneRemoteName="sgdrive_media" # Name of rclone remote mount WITHOUT ':'. NOTE: Choose your encrypted remote for sensitive data RcloneMountShare="/mnt/user/sgdrive_media_rclone" # where your rclone remote will be located without trailing slash e.g. /mnt/user/mount_rclone MergerfsMountShare="/mnt/user/sgdrive_media" # location without trailing slash e.g. /mnt/user/mount_mergerfs. Enter 'ignore' to disable DockerStart="PlexMediaServer NZBGet sonarr radarr radarr4k ombi tautulli" # list of dockers, separated by space, to start once mergerfs mount verified. Remember to disable AUTOSTART for dockers added in docker settings page LocalFilesShare="/mnt/user/sgdrive_media_local" # location of the local files and MountFolders you want to upload without trailing slash to rclone e.g. /mnt/user/local. Enter 'ignore' to disable MountFolders=\{"Movies,Movies-UHD,Music,Other,Personal,TV,TV-Kids"\} # comma separated list of folders to create within the mount #!/bin/bash ###################### ### Upload Script #### ###################### ### Version 0.95.6 ### ###################### ####### EDIT ONLY THESE SETTINGS ####### # INSTRUCTIONS # 1. Edit the settings below to match your setup # 2. NOTE: enter RcloneRemoteName WITHOUT ':' # 3. Optional: Add additional commands or filters # 4. Optional: Use bind mount settings for potential traffic shaping/monitoring # 5. Optional: Use service accounts in your upload remote # 6. Optional: Use backup directory for rclone sync jobs # REQUIRED SETTINGS RcloneCommand="move" # choose your rclone command e.g. move, copy, sync RcloneRemoteName="sgdrive_media" # Name of rclone remote mount WITHOUT ':'. RcloneUploadRemoteName="sgdrive_media" # If you have a second remote created for uploads put it here. Otherwise use the same remote as RcloneRemoteName. LocalFilesShare="/mnt/user/sgdrive_media_local" # location of the local files without trailing slash you want to rclone to use RcloneMountShare="/mnt/user/sgdrive_media_rclone" # where your rclone mount is located without trailing slash e.g. /mnt/user/mount_rclone MinimumAge="15m" # sync files suffix ms|s|m|h|d|w|M|y ModSort="ascending" # "ascending" oldest files first, "descending" newest files first And I noticed this resulted in the following share directories, /mnt/user/sgdrive_media_local/sgdrive_media /mnt/user/sgdrive_media_rclone/sgdrive_media /mnt/user/sgdrive_media/sgdrive_media My current Media share is; /mnt/user/Media/ My concern is if I point my local directory at that, it's going to look for /mnt/user/Media/sgdrive_media/ - Which does not exsist/emtpy. What is the best way to accomplish this? Thank you.
  5. I didn't add the service accounts to the Team Drive, seemed to have resolved it
  6. Alright, so I think I have an issue with my service accounts. This is all very new to me, but I did my best to follow documentation. I followed the instructions to create service accounts from here; https://rclone.org/drive/#1-create-a-service-account-for-example-com. I created 5 of them yesterday, I did it manually because I was unable to get the AutoRclone to work on my Windows machine. I put the following command in terminal, and it seemed to work properly and list the folders in the root of my Shared Drive. # rclone -v --drive-impersonate me@mydomain.com lsf gdrive: Media/ Test/ This is the log from the mount script; 10.04.2020 08:32:26 INFO: Creating local folders. 10.04.2020 08:32:26 INFO: *** Starting mount of remote sgdrive_media 10.04.2020 08:32:26 INFO: Checking if this script is already running. 10.04.2020 08:32:26 INFO: Script not running - proceeding. 10.04.2020 08:32:26 INFO: Mount not running. Will now mount sgdrive_media remote. 10.04.2020 08:32:26 INFO: Recreating mountcheck file for sgdrive_media remote. 2020/04/10 08:32:26 DEBUG : rclone: Version "v1.51.0-151-gfc663d98-beta" starting with parameters ["rcloneorig" "--config" "/boot/config/plugins/rclone-beta/.rclone.conf" "copy" "mountcheck" "sgdrive_media:" "-vv" "--no-traverse"] 2020/04/10 08:32:26 DEBUG : Using config file from "/boot/config/plugins/rclone-beta/.rclone.conf" 2020/04/10 08:32:27 DEBUG : mountcheck: Need to transfer - File not found at Destination 2020/04/10 08:32:27 ERROR : mountcheck: Failed to copy: failed to make directory: googleapi: Error 404: File not found: REMOVED., notFound 2020/04/10 08:32:27 ERROR : Attempt 1/3 failed with 1 errors and: failed to make directory: googleapi: Error 404: File not found: REMOVED., notFound 2020/04/10 08:32:28 DEBUG : mountcheck: Need to transfer - File not found at Destination 2020/04/10 08:32:29 ERROR : mountcheck: Failed to copy: failed to make directory: googleapi: Error 404: File not found: REMOVED., notFound 2020/04/10 08:32:29 ERROR : Attempt 2/3 failed with 1 errors and: failed to make directory: googleapi: Error 404: File not found: REMOVEDD., notFound 2020/04/10 08:32:29 DEBUG : mountcheck: Need to transfer - File not found at Destination 2020/04/10 08:32:29 ERROR : mountcheck: Failed to copy: failed to make directory: googleapi: Error 404: File not found: REMOVED., notFound 2020/04/10 08:32:29 ERROR : Attempt 3/3 failed with 1 errors and: failed to make directory: googleapi: Error 404: File not found: REMOVED., notFound 2020/04/10 08:32:29 INFO : Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA - Errors: 1 (retrying may help) Elapsed time: 1.9s 2020/04/10 08:32:29 DEBUG : 10 go routines active 2020/04/10 08:32:29 Failed to copy: failed to make directory: googleapi: Error 404: File not found: REMOVED., notFound 10.04.2020 08:32:29 INFO: *** Creating mount for remote sgdrive_media 10.04.2020 08:32:29 INFO: sleeping for 5 seconds 2020/04/10 08:32:30 INFO : Google drive root 'Media': Failed to get StartPageToken: googleapi: Error 403: The attempted action requires shared drive membership., teamDriveMembershipRequired 10.04.2020 08:32:34 INFO: continuing... 10.04.2020 08:32:35 CRITICAL: sgdrive_media mount failed - please check for problems. Script Finished Fri, 10 Apr 2020 08:32:35 -0500 Edit: Rclone Config gdrive:Media - Media is the folder residing in my Shared Drive [gdrive] type = drive scope = drive service_account_file = /mnt/user/appdata/other/rclone/service_accounts/unraid_sa1.json team_drive = REMOVED server_side_across_configs = true [sgdrive_media] type = crypt remote = gdrive:Media filename_encryption = standard directory_name_encryption = true password = REMOVED password2 = REMOVED
  7. I am in the early stages of this process, and didn't fully understand the standard Drive vs Team Drive. I have < 1tb of data currently uploaded, and roughly 4tb pending upload on my local share that I am migrating to that share. If I was to move my existing stuff into the team drive, would I just need to just re-do my rclone config with the same names but this time as a Team Drive? Would my data currently only on my local gdrive share be ok?
  8. Anyone have this running and an available template?
  9. Yes I agree. I did what user creon did on page 12; "/mnt/disk1/appdata/unifi/ was /mnt/user/appdata/unifi/" and it fixed it. Unraid version 6.2.4
  10. Having issues with this docker, I have it running on a 2nd Unraid server fine. Having issues on this server. Docker is started and appears running ok, however I cannot access WebGUI via port 8443. Config: Unifi Log: [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 10-adduser: executing... ------------------------------------- _ _ _ | |___| (_) ___ | / __| | |/ _ \ | \__ \ | | (_) | |_|___/ |_|\___/ |_| Brought to you by linuxserver.io We gratefully accept donations at: https://www.linuxserver.io/index.php/donations/ ------------------------------------- GID/UID ------------------------------------- User uid: 99 User gid: 100 ------------------------------------- [cont-init.d] 10-adduser: exited 0. [cont-init.d] 20-config: executing... [cont-init.d] 20-config: exited 0. [cont-init.d] 30-keygen: executing... [cont-init.d] 30-keygen: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. [s6-finish] sending all processes the KILL signal and exiting. [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 10-adduser: executing... usermod: no changes ------------------------------------- _ _ _ | |___| (_) ___ | / __| | |/ _ \ | \__ \ | | (_) | |_|___/ |_|\___/ |_| Brought to you by linuxserver.io We gratefully accept donations at: https://www.linuxserver.io/index.php/donations/ ------------------------------------- GID/UID ------------------------------------- User uid: 99 User gid: 100 ------------------------------------- [cont-init.d] 10-adduser: exited 0. [cont-init.d] 20-config: executing... [cont-init.d] 20-config: exited 0. [cont-init.d] 30-keygen: executing... [cont-init.d] 30-keygen: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. Unraid Log: Dec 29 15:08:03 Tech_Server shfs/user: err: shfs_write: write: (22) Invalid argument Dec 29 15:08:07 Tech_Server shfs/user: err: shfs_write: write: (22) Invalid argument Dec 29 15:08:11 Tech_Server shfs/user: err: shfs_write: write: (22) Invalid argument Dec 29 15:08:15 Tech_Server shfs/user: err: shfs_write: write: (22) Invalid argument Any help appreciated, thanks!
  11. Did you ever get this to work?
  12. Hello, Does anyone know how I can get this docker to run as a docker in unraid? https://hub.docker.com/r/sidesplitter/musicbot/ Thanks.
  13. There's a known flaw with connections as fast as yours and the speedtest python script, mainly the upload speed. The author of the script is aware and it's on his todo list. That said there will always be a differences which is stated in the op right before the change log. Thank you for responding!
  14. Any thought as to why I see a large difference between my browser and the unraid plugin? Local browser is the faster of the two