• Posts

  • Joined

  • Last visited


  • Gender

nallar's Achievements


Newbie (1/14)



  1. docker run -d --name="smokeping" --net="none" -e TZ="Europe/London" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -v "/mnt/user/appdata/smokeping":"/data":rw -v "/mnt/user/appdata/smokeping":"/config":rw -h --network homenet --ip linuxserver/smokeping
  2. Log: This is an hour or so after starting. It would usually have FPing: probing 12 targets with step 23 s and offset 6 s. repeated many times by this point, not just once. Database: Targets: Definitely used to work, you can see here when it stopped recording:
  3. Broken for me too after updating. Looks like this change killed it:
  4. Any chance of getting this merged?
  5. I think it's just because you're on ubuntu trusty/LTS which was released in 2014. They're only including security updates to avoid breaking changes, so nginx is frozen at version 1.4 which was the current version at the time. Ubuntu vivd has nginx 1.6.2, wily includes nginx 1.9.3. If you used ppa:nginx/stable, you'd get nginx 1.8 which doesn't have http2 support (it was introduced in 1.9), but does add some other useful features which aren't in 1.4 such as weak etags for gzipped content. ppa:nginx/development (which tracks nginx mainline versions) does include http2. The nginx release notes are here: If the nginx version is updated, http2 won't be on by default. It's only enabled if "http2" is added to your listen directive(s), for example "listen 443 default_server ssl http2;". I believe there is a breaking change between nginx 1.4 and 1.9 with the default configs. The line "include /etc/nginx/fastcgi_params;" needs to be changed to "include /etc/nginx/fastcgi.conf;". To avoid any impact for users of the container, after performing the update /etc/nginx/fastcgi_params could be symlinked to /etc/nginx/fastcgi.conf. edit: If the repositories are changed, it's probably best to change to ppa:nginx/stable, not development. That doesn't have http2 yet. It tracks official nginx stable releases.
  6. It survives rebooting, doesn't survive editing the container or updating the container. Any chance of getting the container to include repositories with a more recent version of nginx by default? The current version (1.4+backported security fixes) is nearly two years old.
  7. Steps to upgrade to nginx mainline (currently 1.9.10): docker exec -it Nginx bash add-apt-repository ppa:nginx/development apt-get update apt-get -y dist-upgrade To check your config is correct before restarting, you can run: nginx -tc /config/nginx/nginx.conf
  8. I'm seeing the same problem with leftover symlinks on the cache drive. There's an older thread here which seems to be about the same problem:
  9. Is there a way to set the vars used in /home/nobody/ I did it by changing that file in the container (set Could include a script from /config which would be able override those settings? I also needed to install git and jdk8-openjdk using pacman, then set up and with git config. How do I make those changes persistent?
  10. How can I update the version of nginx to one which supports HTTP2? The version in the docker is 1.4.6. HTTP2 has been supported since 1.9.5. I see that the docker automatically updates when starting, but from ubuntu trusty repos which have an old version of nginx. A newer version is available in: deb trusty nginx deb-src trusty nginx
  11. If you use the button for webui in the Unraid docker management it takes you right there and we've put it in the readme, but I'll pass on the redirect request as well. Hadn't even noticed that was there, I'd been clicking the links under port mappings. /facepalm Sorry for wasting your time!
  12. Yes, it works fine. I didn't try /cgi-bin/smokeping.cgi, sorry. Might be a good idea to replace the apache default index.html with a redirect to smokeping.
  13. This doesn't seem to work, I just see the default apache index.html page. Logs (lack of anything going on here): Running "smokeping" in a shell in the container gives: root@2478b7cc6600:/var/www/html# smokeping ERROR: loading smokeping configuration file /usr/sbin/../etc/config: No such file or directory