Jump to content

Kru-x

Community Developer
  • Content Count

    140
  • Joined

  • Last visited

  • Days Won

    1

Kru-x last won the day on May 18

Kru-x had the most liked content!

Community Reputation

13 Good

About Kru-x

  • Rank
    Advanced Member
  • Birthday 09/28/1966

Converted

  • Gender
    Male
  • Location
    Australia

Recent Profile Visitors

1011 profile views
  1. Hi Greg, Glad to hear it is running well, a server time out is not really related to this setup and I'm not sure. Really can't help you, ask in a general WP forum, could be anything. But to give you a starting point, you can increase the time b4 it times out both in wp-config and in NginX (NPM) but I am not sure why this would be needed. Maybe ask the plugin developer. I use wkhtmltopdf to generate pdf's from HTML pages, but that is a lot off hassel and have to be built in to the WP docker container in this setup. Sorry I can't be of more help, Kru-x
  2. I think it is becouse you did the WP installer on your internal address, always creates a lot of havocs. Delete your folders and DB and start from the beginning, ones you have your domain up running then start the wp installer, Kru-x Ps. read some of the threads earlier in this forum, its a common issue that many run in to.
  3. Did you install WordPress from you domain or local? Kru-x
  4. Hi broadcastthebadger, If you have used this docker for a while it is probably that you have the old one, the old one broke and I changed it to another one, should be in said in this forum I think. Anyhow check if you have jwater7/godaddy-publicip-updater in the repository column, if not delete the image and my template and use the new one in the apps library. Hope it helps, Kru-x
  5. Don't worry, Godaddy is a domain name provider and you are paying for it! The service as a website hosting is just a side kick. It won't matter to them if you host it or another provider douse it, same for them and it is a reason they provider an api to change it.. Kru-x
  6. Sa du fick det att funka? Kru-x
  7. Wish it was that easy, 🙂 But all references to pages, post, comments etc. are saved into the Database (thats how WordPress do much of it's workings), thats why it is better to start from scratch or you have to find all those faulty references in the DB manually. As I have mentioned in previous posts, there is good programs (plugins) that will do this for you if you have a site already or is working in a development environment. Kru-x
  8. Then it is that you installed WP on your local ip address first, it's WordPress that redirects to the same ip that it was installed on. To explain what I believe is happening, during installation WP created an index.php page (the homepage) that have a an address of IP:8080 and saves that info in to the database. And even if you change the site's domain he will still redirect to domain:8080. That's why I always recommend installing from your domain first. Kru-x
  9. Sounds like you are only using one instance of a MariaDB, whilst you could, I always make a new instance of the database eg. so two containers for each site ex wp-temp & wp-temp-MariaDB. Makes it much easier to fire one site up and delete it when needed. The "issue" with the webUI, it should auto change to the port that you add in the template, if not you can change it your self in advance view and correct the WebUI: http://[IP]:[PORT:8080]/ it works the same with all containers in unraid. Kru-x
  10. You can create as many instances of WordPress as you like and it seems you have figured it out, create different containers with different ports and that should be it. Seems like you are confident enough to change user permission and wp-config.php, that is good if you are but in a basic setup you shouldn't need to, the MariaDB is accessed by WP as root user with full privileges and the installation takes care of the directions in the wp-config.php file, both if you just use the regular settings in the template. And just a side note, if you start the install from the internal ip address that is the address that is used, might be easy enough to change b4 you have done any changes or added any pages but if you work a bit on the site and then wants to get it on a domain address you are in for a ride, much of the internal working of WP is relying on the info in the DB. I always suggest to do a clean install from the domain name and work from there, if there is a site you have worked on or a development instance, move it to the clean instal of that domain by using a plugin, I always use "Duplicator Pro". Kru-x
  11. Nahhh, it will only replace a file that is missing but not overwriting. So your _.php might pop up again, not that I know what that is , never seen one myself.
  12. Hi, The root folder is the one you created when you added the container, as per below "/mnt/user/appdata/wordpress-temp/". The php.ini is not there by default but you can add one. I have had more success with .htaccess method to increase the upload limit. Kru-x
  13. HI dancue, Personally I run all my containers in Bridged mode, but I know many is using Spaceinvaders guide and are using a "proxynet" that creates a separate "internal" network. Many swear by it and I have read that it might be better for a proxy routing traffic. Having said that, only ones I have had the need to use a specific separate network and even then later on I switched back to bridge mode again and got it working. For me it is just easier to use one network as I know exactly what the different IPaddresses are on each box (i got two servers). You don't need to add a "custom location" as per your screen shots otherwise it looks right and as for your setup, I guess you installed WordPress from your internal ip address and not on your Domain name, eg remove both the WP and MariaDB's folders and add the two containers again, then check if you can see WP's installation page on your local address but without starting the install, then try to connect to it from your domain name and do the install from there. Hope it helps, Kru-x
  14. Thanks for that explanation Squid, didnt know that, Kru-x
  15. Hi ingarb, I understand what you are saying but not why ;-), It works like this, first time you add a container you download a/my template (in this case my WP), then as soon as you save it, it is saved in a template directory with all your modified settings, any subsequent use should use the modified template, do you delete the templates in between? I don't get it, Also why would you try to remove the port mapping, 80 is the port inside the container to communicate with the "outside world" and the port you add is the port you communicate with from the outside. How are you doing it otherwise? Kru-x