cheesemarathon

Members
  • Posts

    285
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by cheesemarathon

  1. Easy fix. You're using the env variables that minio has depreciated. I updated the template but they don't seem to have pulled through to you. Remove your container and create it again from community apps. Just don't delete your minio appdata as well!!!! @pervel This should also fix your issue. I have just done the above as well and had no issues. Just make sure to fill in your same user and password as before.
  2. I’ll have a poke in my system tonight as I haven’t updated mine yet. I did make a change to the template to fall inline with changes minio made to the env variables so maybe I cocked that up. Could you send a screenshot of your minio docker setup page in the unbraid ui? Thanks
  3. Images have timed out, but here is one of my configs: server { listen 80; server_name app.domain.com; return 301 https://$server_name$request_uri; } server { listen 443 ssl; server_name app.domain.com; ssl_certificate /config/keys/letsencrypt/fullchain.pem; ssl_certificate_key /config/keys/letsencrypt/privkey.pem; ssl_prefer_server_ciphers on; add_header Strict-Transport-Security max-age=2592000; location /oauth2/ { proxy_pass http://192.168.1.41:4180; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Scheme $scheme; proxy_set_header X-Auth-Request-Redirect $request_uri; } location = /oauth2/auth { proxy_pass http://192.168.1.41:4180; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Scheme $scheme; # nginx auth_request includes headers but not body proxy_set_header Content-Length ""; proxy_pass_request_body off; } location / { auth_request /oauth2/auth; error_page 401 = /oauth2/sign_in; # pass information via X-User and X-Email headers to backend, # requires running with --set-xauthrequest flag auth_request_set $user $upstream_http_x_auth_request_user; auth_request_set $email $upstream_http_x_auth_request_email; proxy_set_header X-User $user; proxy_set_header X-Email $email; # if you enabled --cookie-refresh, this is needed for it to work with auth_request auth_request_set $auth_cookie $upstream_http_set_cookie; add_header Set-Cookie $auth_cookie; include /config/nginx/proxy.conf; add_header X-Frame-Options SAMEORIGIN; proxy_pass http://192.168.1.41:9080; } }
  4. I have just updated the template for minio. It should fix all the issues of recent.
  5. Looks like minio have made some changes to their container. I'll read the docs and update the template this evening!
  6. Thanks for the update! @hmoney007 try frankman's suggestion.
  7. Like i said before I don't run Nginx proxy manager I run SWAG by linuxserver, but that uses nginx so my configs should work for you. I just wrote the one below and it loads fine on my server and domain. Just don't forget to change the XXX.XXX bit for your IP and change yourdomain for your domain. Also if your running cloudcmd on a different port to 8765 then you will have to change that also. This config assumes that you run cloudcmd as a sub domain rather than a sub directory e.g. cloudcmd.mydomain.com not mydomain.com/cloudcmd I hope that all makes sense 🙂 just shout if not. server { listen 80; server_name cloudcmd.mydomain.com; return 301 https://$server_name$request_uri; } server { listen 443 ssl; server_name cloudcmd.mydomain.com; ssl_certificate /config/keys/letsencrypt/fullchain.pem; ssl_certificate_key /config/keys/letsencrypt/privkey.pem; ssl_prefer_server_ciphers on; add_header Strict-Transport-Security max-age=2592000; location / { proxy_pass http://XXX.XXX.XXX.XXX:8765/; } }
  8. Have you tried reverting to version 4.0? You can do this by opening the container settings in the unRAID UI and then changing the repository value from "ghost" to "ghost:4" With regards to your friends question, I do not provide the container image. The ghost organisation builds and manages the image. I just provide a template for unRAID. This template will automatically use the latest image provided by the ghost organisation. There should be no issue with this but if you are concerned you can fix the version you run the same way I describe in the previous paragraph or you can turn off automatic updates for the ghost container and just run them manually when you are happy the update is stable. As for removing the index, if your having the same issue as one of the other commenters (I've not seen your logs so I can't be sure) then running the below should remove the index causing issues. I would backup your db before touching it however. Make sure that the ghost container is not running whilst you make changes. alter table `migrations_lock` drop key migrations_lock_lock_key_unique As for the issues with mysql-workbench I would recommend HeidiSQL for Windows and DBeaver for Mac. Both work well with Maria/MySQL databases. Failing this, ask for help at the Ghost forum where this issue may have been seen before.
  9. My nginx config is below. I also use oauth2 proxy so you will need to remove those sections. server { listen 80; server_name cloudcmd.MYDOMAIN.com; return 301 https://$server_name$request_uri; } server { listen 443 ssl; server_name cloudcmd.MYDOMAIN.com; ssl_certificate /config/keys/letsencrypt/fullchain.pem; ssl_certificate_key /config/keys/letsencrypt/privkey.pem; ssl_prefer_server_ciphers on; add_header Strict-Transport-Security max-age=2592000; location /oauth2/ { proxy_pass http://UNRAID_IP:4180; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Scheme $scheme; proxy_set_header X-Auth-Request-Redirect $request_uri; } location = /oauth2/auth { proxy_pass http://UNRAID_IP:4180; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Scheme $scheme; # nginx auth_request includes headers but not body proxy_set_header Content-Length ""; proxy_pass_request_body off; } location / { auth_request /oauth2/auth; error_page 401 = /oauth2/sign_in; # pass information via X-User and X-Email headers to backend, # requires running with --set-xauthrequest flag auth_request_set $user $upstream_http_x_auth_request_user; auth_request_set $email $upstream_http_x_auth_request_email; proxy_set_header X-User $user; proxy_set_header X-Email $email; # if you enabled --cookie-refresh, this is needed for it to work with auth_request auth_request_set $auth_cookie $upstream_http_set_cookie; add_header Set-Cookie $auth_cookie; proxy_pass http://UNRAID_IP:8765/; } }
  10. Have you checked you can connect to the db with the same username and password? I agree it's very strange but the only error it is reporting is connection refused.
  11. Have you tried removing the index as mentioned earlier?
  12. Looks like Ghost can't connect to your db. Check it's running and available from another service.
  13. Yes in the docker settings where it says repository change it from ghost to ghost:4.0 4.1.0 is the latest so that should roll you back a bit.
  14. I’m not 100% sure what’s going on, but it looks like ghost is trying to modify a database and a key that already exists. I don’t know how to fix this unfortunately and a quick google didn’t turn up anyone else having the same issue. I suggest you ask for help at https://forum.ghost.org/ If you link your post here I will keep an eye on it. Thanks and sorry I couldn’t help more
  15. I believe it is because ghost is expecting a connection over https. Your ssl cert is bound to your domain name so browsing to it via internal IP things are not gonna match up. Just browse it via your domain and you will be fine. You haven't done anything wrong.
  16. Still having issues: crond: USER root pid 8 cmd PATH=$PATH:/usr/bin /usr/bin/borgmatic prune create -v 1 --stats 2>&1 /etc/borgmatic.d/config.yaml: Running command for pre-backup hook Wed Nov 25 19:19:00 UTC 2020 - Starting backup ba627szn@ba627szn.repo.borgbase.com:repo: Pruning archives Remote: ba627szn@ba627szn.repo.borgbase.com: Permission denied (publickey). Connection closed by remote host. Is borg working on the server? ba627szn@ba627szn.repo.borgbase.com:repo: Error running actions for repository Command 'borg prune --keep-daily 3 --keep-weekly 4 --keep-monthly 12 --keep-yearly 2 --prefix {hostname}- --stats --info ba627szn@ba627szn.repo.borgbase.com:repo' returned non-zero exit status 2. /etc/borgmatic.d/config.yaml: Error running configuration file summary: /etc/borgmatic.d/config.yaml: Error running configuration file ba627szn@ba627szn.repo.borgbase.com:repo: Error running actions for repository Remote: ba627szn@ba627szn.repo.borgbase.com: Permission denied (publickey). Connection closed by remote host. Is borg working on the server? Command 'borg prune --keep-daily 3 --keep-weekly 4 --keep-monthly 12 --keep-yearly 2 --prefix {hostname}- --stats --info ba627szn@ba627szn.repo.borgbase.com:repo' returned non-zero exit status 2. Need some help? https://torsion.org/borgmatic/#issues File perms: ~/.ssh # ls -al total 8 drwx------ 1 99 users 40 Nov 22 20:24 . drwx------ 1 root root 58 Nov 25 19:13 .. -rw------- 1 root root 464 Nov 22 19:39 borgmatic -rw------- 1 root root 202 Nov 22 19:44 known_hosts
  17. Hi, im having issues with SSH key permissions. What should i set them to?
  18. This is what I have done, and its not working. I can't see what im missing. My torrent.rc file must be good as its clearly trying to use the correct port. Did you make any changes to the mulvad openVPN config files. It's the only other place I can see it going wrong.
  19. Then the only thing I can think is that perhaps your line endings have gone wrong. I have attached my config, minus my secrets. I marked the values that you need to replace with REPLACE_ME then replace your existing config with my one, as I know mine works. Make sure you use an editor that adheres to linux file line endings such as notepad++ oauth2_proxy.cfg
  20. Has anyone managed to get port forwarding working with Mullvad? I have the VPN connection working but rtorrent reports the port is closed.
  21. Can you confirm what files you have in /mnt/user/appdata/oauth2/ You should have emails.cfg and oauth2_proxy.cfg I couldn't tell from your screenshot.
  22. Everything there looks ok. Have you put an email in the emails.cfg file to authenticate against?