Jump to content

poldim

Members
  • Content Count

    68
  • Joined

  • Last visited

Everything posted by poldim

  1. @Viaduct - Thanks for the script! I tweaked the. regex a bit to include the decimal places as my current draw was below 1. Seems to be working well. Will the crontab settings save reboots or does it need to be added to the GO script? preg_match("/".$tag.".*(\b\d+\b\.\d\d).*$/mi", $output, $match);
  2. Anyone have any ideas why my LE docker cannot ping the unraid IP? I've got LE bound to a custom IP of 10.1.1.8 while my unraid is 10.1.1.10. Certs went through fine, but cannot successfully ping the unraid IP: Trying to RP to my homeassistant docker and getting a `failed (113: Host is unreachable) while connecting to upstream` error docker exec -it letsencrypt /bin/bash root@e01490db42ac:/$ curl http://10.1.1.10:8123/ curl: (7) Failed to connect to 10.1.1.10 port 8123: Host is unreachable root@e01490db42ac:/$ ping 10.1.1.10 PING 10.1.1.10 (10.1.1.10): 56 data bytes ^C --- 10.1.1.10 ping statistics --- 14 packets transmitted, 0 packets received, 100% packet loss root@e01490db42ac:/$ ping 10.1.1.1 PING 10.1.1.1 (10.1.1.1): 56 data bytes 64 bytes from 10.1.1.1: seq=0 ttl=64 time=0.475 ms 64 bytes from 10.1.1.1: seq=1 ttl=64 time=0.383 ms 64 bytes from 10.1.1.1: seq=2 ttl=64 time=0.391 ms 64 bytes from 10.1.1.1: seq=3 ttl=64 time=0.378 ms ^C --- 10.1.1.1 ping statistics --- 4 packets transmitted, 4 packets received, 0% packet loss round-trip min/avg/max = 0.378/0.406/0.475 ms root@e01490db42ac:/$ ping 10.1.1.8 PING 10.1.1.8 (10.1.1.8): 56 data bytes 64 bytes from 10.1.1.8: seq=0 ttl=64 time=0.072 ms 64 bytes from 10.1.1.8: seq=1 ttl=64 time=0.063 ms ^C --- 10.1.1.8 ping statistics --- 2 packets transmitted, 2 packets received, 0% packet loss round-trip min/avg/max = 0.063/0.067/0.072 ms
  3. Followed the guide here. Used default go file Fix Common Problems Alerts before upgrading: **** unRaid's built in FTP server is currently disabled, but users are defined **** **** Dynamix SSD Trim Plugin Not installed **** Booting into safe mode with GUI still does not launch GUI and array is not started. I checked syslog for errors and did not find anything. Anything else I should try before replacing the key?
  4. I tried rsync and it stopped after 955GB with plenty of free space on the drive. I tried Krusader and when I copy the files over, it seems Krusader doesn't have access to write to the new drive? How can I fix that?
  5. Got the first problem resolved, now need the best way to transfer the data
  6. I've about 7TB worth of data that I need copy off of my array. I've installed a 2x 12TB drives where I'd like to copy the data to? What is the best way to copy or move the files over? I've read this. Krusader? SSH cp command with nohup? Any other recommendations? EDIT: Resolved drive size issue.
  7. I'd love to do that, but I can't seem to get it working. Basically it would be two services that come in on port 80 but would need to go to two different locations. Do you have any hints/guides/examples?
  8. Does anyone have LE running with a pihole (pi-hole) container? I'm trying to get something like this https://hub.docker.com/r/diginc/pi-hole/ running but not sure how to setup LE / nginx config to prevent breaking my existing forwards. I have a wordpress site that externally hosted on 80 and also want to have the pihole
  9. My setup: 192.168.2.0/24 - VLAN 20 - HOMELAB 192.168.3.0/24 - VLAN 30 - HOME AUTOMATION 192.168.4.0/24 - VLAN 40 - WLAN 192.168.5.0/24 - VLAN 50 - GUEST [Subnet routing only blocked for GUEST VLAN.] What happens: 4G connection from cell -> nginx reverse proxy = works VM on HOMELAB VLAN -> nginx reverse proxy = works VM on HOME AUTOMATION VLAN -> nginx reverse proxy = does not work phone/laptop on WLAN VLAN -> nginx reverse proxy = does not work phone/laptop on WLAN VLAN -> IP of service on HOMELAB VLAN = works The unraid server has the letsencrypt / nginx docker. The server sits on 192.168.2.100 VLAN 20 but is bridged to 192.168.3.100 VLAN 30 and 192.168.4.100 VLAN 40. I added the networking settings to the gdoc https://docs.google.com/document/d/1Cf8qLFcBVAen3yxqcOzA3kI_KbaRuS582b7yE7X7J1Q/edit?usp=sharing What does not make sense to me: I can access the UniFi UI on 192.168.2.100 from my macbook or phone which are 192.168.4.1xx I can access my security cameras that are 192.168.3.xxx from the same macbook/phone and VM hosted on 192.168.2.xxx. Doesn't this mean that subnet routing is, in fact, working correctly? Is this correct while on WAN: unifi.mydomain.com Phone > DNS lookup and send me to my router > router forwards 80 + 443 to 80 and 443 on my unraid server > letsencrypt is bound to those ports, receives the request, and forwards to the appropriate internal address based on config. If I have hairpin NAT enabled, is the process the same? Does the lookup for unifi.mydomain.com not get routed by the router back to the unraid server?
  10. Here are all of the relevant settings that I can think of: https://docs.google.com/document/d/1Cf8qLFcBVAen3yxqcOzA3kI_KbaRuS582b7yE7X7J1Q/edit?usp=sharing
  11. Any ideas on anything else to check? I have no issues accessing the resources while on the LAN across subnets. Makes me think it's some kind of nginx setting...
  12. I discovered that my problem was appending the URL with the final destination. IE: proxy_pass https://192.168.2.100:32400/web/index.html; does not work, but removing "/web/index.html" makes it happy: proxy_pass https://192.168.2.100:8443; I've now got access to both my unifi and plex interface on my phone while on 4G. BUT, I'm still unable to connect while connected to the WIFI in the house. Are there some kind of additional settings in nginx to allow it to route the connection between VLANs? My wifi is on a separate VLAN but I have no issues hitting the direct IP of the interfaces. When trying to access the subdomain.domain.com I get the following error: ERR_EMPTY_RESPONSE or ERR_CONNECTION_TIMED_OUT
  13. Anyone have any recommendations on what I could look at to try to solve this?
  14. Still having trouble with this. THESE are my current domain settings. I've tried having both 'www' and '@' before .mydomain.com and still noting. This is my default config: server { listen 443 ssl; root /config/www/unifi; index index.html index.htm index.php; server_name unifi.*; ssl_certificate LOCATION_REDACTED; ssl_certificate_key LOCATION_REDACTED; ssl_dhparam LOCATION_REDACTED; ssl_ciphers 'CIPHER_REDACTED'; ssl_prefer_server_ciphers on; client_max_body_size 0; location = / { include /config/nginx/proxy.conf; proxy_pass https://192.168.2.100:8443/manage/account/login; } } EDIT: So I added the CNAME records for www + unifi and sending them to @. I then pulled up http://unifi.mydomain.com/ on my mac and get nothing. I tried my phone on wifi and it timed out. I tried my phone on 4G and am getting THIS: Outdated Browser You are using an outdated browser. Please upgrade your browser to improve your experience. {{toast.message}} Partial success as it's prompting to open the unifi app....now how do I get it to work?
  15. Anyone have a breakdown on how to make a certificate for unifi that lives in this docker?
  16. So I found I can use this to display in GB: btrfs filesystem df /mnt/cache/ But I've found that this function does not support wildcards. How do I get the equivalent of this: du --si -s /mnt/cache/* 54G /mnt/cache/appdata 55G /mnt/cache/system 92G /mnt/cache/vdisks I'm essentially trying to see a folder output view with their file sizes to try to understand what's using up more space than it should.
  17. I be got a pair of 250GB SSDs setup as the cache. Currently it's showing red as is says they are 226GB full. http://i.imgur.com/8bqUbPu.png du -sh /mnt/cache/ 187G /mnt/cache/ du --si -s /mnt/cache/ 200G /mnt/cache/ Where is the extra 26GB coming from?
  18. This is odd, when I restart my docker, the upload limit is 4.7 Mb/s and download is 9.7 Mb/s. I havent changed my rtorrent.rc file which still states download_rate = 10000 upload_rate = 5000
  19. The upload rate is one of the few settings that is consistently getting wiped after each update. Where is the upload rate set in the config manually?
  20. How can I make the upload speed limit a persistent setting that survives docker updates?
  21. yea, i get mapping. all of my dockers follow the standard appdata folder structure. no plugins folder, and there isnt one in the sub folders either. root@ChiRAID:/mnt/user/appdata/rutorrent# ls -l total 0 drwxr-xr-x 1 poldim users 44 Dec 15 00:09 log/ drwxr-xr-x 1 poldim users 20 Dec 15 00:09 nginx/ drwxr-xr-x 1 poldim users 14 Dec 15 00:09 php/ drwxr-xr-x 1 poldim users 48 Dec 15 19:12 rtorrent/ drwxr-xr-x 1 poldim users 32 Dec 15 19:12 rutorrent/
  22. How can I change the permissions settings of the new files that ruTorrent makes? It looks like it's currently making them as drwxr-xr-x which isn't giving couchpotato the ability to rename and move the files automatically. Can RU make the files with 777 file permissions?
  23. I have, no plugins folder in the appdata folder nor within the docker itself.
  24. How can I use this, https://github.com/xombiemp/rutorrentMobile, which needs to be installed in the plugins directory? Is this a folder that I would need to map myself or does it need to exist elsewhere?