Rooie

Members
  • Content Count

    21
  • Joined

  • Last visited

Everything posted by Rooie

  1. My understanding is that matrix basically just meshes all these things together. Riot would allow you to call or text users you add. If you wanted to just call anyone you might have to do some searching to find the app that works for that
  2. Anyone know if there is a guide out there for hosting bots? I’ve done some google searching but haven’t found anything useful yet
  3. Have had luck with jitsi inside of this? I added that widget, which of course sends me out of my server to some other server hosting it but I would like to make that widget use the jitsi I already host
  4. its weird because when I invite Giphy to the room i get this so it looks like it is there, but it never does anything when i type !giphy anything wonder if there is a way to host the bot as well that way i don't have go through matrix.org is there any chance its not working because "kiax" is a cell phone/
  5. now don't laugh at me but I've been working on this trying for the better part of two days....why because I want to use this as my primary messaging service. I finally got the green light with federation, so i was attempting to add the final piece I needed...this is the part where you laugh...giphy. I try to load it, it should that it was invited to the room, then nothing. it never joined the room. Am i missing something?
  6. okay so I changed NAT to forward WAN 8488 to LAN 1448 and I still fail the federation check. edit: Got it. miss type on your edit. its not "It SHOULD have said to forward WAN 8448 to LAN 1448" its: It SHOULD have said to forward WAN 8448 to LAN 1443 only pointing it out in case someone is right behind us trying to figure it out. I now pass the federation check. Thank you so much for the back and forth, defiantly could not have gotten this working with out you
  7. do I need to add anything to the homeserver.yaml to tell it to listen to 8448?
  8. Okay so I can’t connect to matrix.mydomain.com:8448 I’ve double checked PFSense and TCP 8448 is forwarded to 192.168.x.x:8448. Same as the other ports (443 to 1443 and 80 to 180). So I’m pretty confident that part is correct in pfsense. I set up my letsencrypt proxy configs according to your your config example file....so I’m not sure what I have wrong
  9. Found those steps and made the adjustments. Still get a failed message when I try to use integrations
  10. Negative. Did I miss that step in the guide? I can handle the firewall part but what should the conf default have in it for 8448?
  11. Negative. When riot first start it actually told me the it could creat the room so I never got the “welcome to riot” message from riot-bot. And obviously I can’t do anything with integration. I created a test user when I went to riot.im and while I was waiting for no one to actually help I decided to invite my test user to chat with me on my server....got an error that it couldn’t find the user.
  12. For your unrelated note...is this the reason I can’t connect with other hosting their own riot-web servers and can only talk to people on my server?
  13. I'm there, so far the ir support page of theirs is pretty dead minus one person asking people to give him money.
  14. Great instructions. I managed to get everything up and running, except I appear to have a federation problem (when I first logged in i didn't get the riot-bot sending me a message welcoming me to riot and i can't get anything with the integration manager to work) and for the life of me I don't know how to get riot to talk with matrix.org. Which isn't really helpful because they don't seem to host a forum where you can ask questions....they do it in riot, which defeats the point if you can't connect to them. Anyone else super smart on riot that can help me fumble through it?
  15. Rooie

    Jitsi?

    Yeah my temp work around is to have my buddy VPN into my network, and when he does that we get video/audio. However giving people the ability to VPN into my network....yeah I've got like one person I trust doing that. So that work around isn't a suitable solution for me. I reached out to @SpaceInvaderOne to see if maybe he could look at my system to spot whats wrong. If he has the time and gives me a hand I'll share what he did and hopefully it helps.
  16. Rooie

    Jitsi?

    so I am able to connect. There just isn't any sound or video. I had the reconnect error last night and I fixed it by adjusting my port forwarding.
  17. Rooie

    Jitsi?

    Okay I got everything working, I'm behind a pfsense, while testing this I can get audio and video, but only while on the same network. (ie if I don't connect my phone to wifi I can connect with jitsi but I get no audio or video). Has anyone else with a similar setup found a fix to this issue?
  18. https://www.amazon.com/dp/B01N5LQ7Z3/ref=cm_sw_r_sms_c_api_i_kVX9CbCBYKCHZ that’s the link for the card. It’s a simple cheap card, but it’s been in the server for nearly two years so this is a new problem. I may try to reseat the controller and possibly just get a new card ordered and assume that this one is just starting to go bad.
  19. Diagnostics attached. I do have a Nvidia Graphics card. It was passed through to a VM, however one of the first things I did while looking into this was to disable VMs wopr-diagnostics-20190604-0430.zip
  20. So all the dockers on my server kinda of just stopped working, however I was able to at least log into the thing. I've attached my log file if anyone can tell me what is going on or how to fix it I would greatly appreciate it. I'm not sure what other information to give you so if you need other information to assist with trouble shooting please let me know and I can provide it. wopr-syslog-20190603-0405.zip