jzawacki

Members
  • Content Count

    27
  • Joined

  • Last visited

Everything posted by jzawacki

  1. Since PiHole has the ability to track individual devices, I would configured the DHCP server to hand out 192.168.1.3 and a fake IP address for the second IP. Then, on PiHole, make it's upstream DNS custom and give it 192.168.1.4. Then, on LanCache server, give it's upstream DNS as your ISP's DNS or 8.8.8.8, or whoever you prefer. Using this method, you retain all the function of PiHole with the benefit of the LanCache server. Just keep in mind that if DHCP hands out more than 192.168.1.3 as a valid IP address, things might not always work correctly, as windows doe
  2. It's funny you say this. The docker run command is correct, all configured properly, but it doesn't make it into the container, I promise. (IP and path redacted) docker run -d --name='unifi-controller' --net='br0' --ip='1.1.1.13' -e TZ="America/Denver" -e HOST_OS="Unraid" -e 'UDP_PORT_3478'='3478' -e 'TCP_PORT_8080'='6759' -e 'TCP_PORT_8443'='6760' -e 'TCP_PORT_8880'='6761' -e 'TCP_PORT_8843'='6762' -e 'UDP_PORT_10001'='10001' -e 'PUID'='99' -e 'PGID'='100' -v '/REMOVED/unifi-controller':'/config':'rw' 'linuxserver/unifi-controller' But, what I was able to end up doing, i
  3. Apologies if this has been addressed, I saw notes around page 8 of others having issues using custom ports, but I couldn't find a solution. It's unfortunate that so much of this thread is standard UniFi controller support over container support. Anyway, I have been unsuccessful using custom ports for this container as well. I have configured the docker properly, but the defaults are still used. If I go into the container and look as the system.properties file, the port options are all commented out, so I'm not sure how the UniFi controller is supposed to know to use the custom p
  4. EXCELLENT FIND! Just as a note, I also had to "fix" the /etc/nginx/sites-available/10_generic.conf you referenced in the link, as mine had the error_log listed twice. I too am now seeing proper "HIT" and "MISS"! Thanks for the info!
  5. I was thinking the same thing, but if all of your DNS servers are running on unRaid anyway, you are basically taking the internet down with unRaid anyway. With that said, I'm still running pfsense on dedicated hardware because I don't trust a docker to not be compromised and your firewall is something important enough to care a little more about than standard dockers. Your firewall is there to protect your network and you would be putting an interface on unRaid directly on the internet. Not really a good idea, IMO.
  6. Interesting. Having both .69 and .13 being used, depending on how your router caches lookups (if it does at all), you may be randomly bypassing the lancache-bundle server. I can't tell you how to setup your network, but I can tell you how I have mine setup, since it sounds like we have similar thoughts. 1) DHCP is handing out the IP address of PiHole and a second IP address that is dead on my network. This keeps Windows from using whatever it wants. If your router isn't able to provide custom DNS IPs for DHCP, I would suggest switching to a DHCP server that does. I
  7. Unfortunately, the "secondary DNS" you added is bypassing the lancache-bundle. Windows doesn't use it as a primary (and if I can't talk to it, use the secondary), it picks whatever IP it wants. What do you get when you try this on the windows computer command prompt: C:\> nslookup Should look like this: Default Server: UnKnown Address: 192.168.1.69 > > google.com Should look like this: > google.com Server: UnKnown Address: 192.168.1.69 Non-authoritative answer: Name: google.com Addresses: 2607:f8b0:400f:80
  8. I'm running a single dedicated IP address on my lancache-bundle at this time and also have a 1Gbps internet connection and seem to have hit a download limit of around 20Mbps through the lancache-bundle server. But, with that said, when I test network equipment within a 1Gbps network, I look for ~950Mbps throughput, so a 1Gbps network should get better than 117Mbps, that would be a limitation to your lancache-bundle hardware, most likely. From what I understand, adding the additional IP addresses should improve your download performance. I'd say give it a shot and report back.
  9. Can't say for sure, but the 404 is a not found error as if the location lancache-bundle is trying to access doesn't have what it's asking for. The 500, 502, 503, and 504 errors are all gateway/server based errors, which would be upstream as well.
  10. Well, if you want to go to your unRaid docker page every time you want to access the web interface of a docker (or memorize a bunch of random ports), knock yourself out. But, your browser defaults to port 80 or 443 (https), so every docker sharing your host IP will need a different port for the web interface. Edit: Ah.. I get it.. you got me.. you are just trolling.. Seems pretty darn clear to me:
  11. You may need to open a cmd prompt as administrator and run: ipconfig /flushdns Once you get pfsense up, you'll be able to watch the bandwidth usage on the status page to you can see if you are using the internet or the cache server as well.
  12. Try this command from your Unraid terminal. What you are looking at are the 200 and 206 numbers. Unfortunatly, I can't tell you which is a HIT and which is a MISS, but if you download something and it shows one of those numbers and the second time you download, it's the other number, it is definitely pulling form the cache server. docker exec -it lancache-bundle tail -f /var/log/nginx/access.log As for bridge vs br0 vs host, I run all my dockers as br0 so they get their own IP address. This makes it so they can all have a web UI on port 80 instead of goofy port numbe
  13. All of your dockers need to have a different IP address than the server.
  14. I would remove 8.8.8.8 as Windows likes to use whatever DNS it wants and using 8.8.8.8 may cause the computer to get the REAL ip address. If windows DNS caches the correct IP, it'll bypass lancache-bundle till the DNS entry expires and it has to ask again. In which case, it may get your cache server or 8.8.8.8 again. 1) Only traffic to the places listed when configuring the docker will be cached. If you don't want to cache something on the list, set it to FALSE 2) I don't think so 3) Depends on how fast you really want it to be. If you have the extra cash and want it
  15. Ok, with that kind of response, you get this kind of response: If you want it to cache something, do you think you should set it to false? Normally, the word false, means you DON'T want it to do something. Therefore, you DO NOT need to change any of those fields. By default, it will cache everything. The only time you would set it to false, is if you DON'T want it to cache something.
  16. Yes, you have to setup your network to use the lancache-bundle as your ONLY internal DNS server. Other than that, not normally. But I am experiencing all kinds of weirdness on it.
  17. Ok, It appears that it might be working, just some of the configs might not be setup the way the devs want them to. I don't know why your log lines are truncated, but when comparing SteamCacheBundle to lancache-bundle, I found that 200 = HIT and 206 = MISS 10.10.10.100 - - [25/Mar/2020:20:27:47 -0600] "GET /tpr/ovw/data/c1/25/c125c5ac589f3ccbdbd632d5249b7878 HTTP/1.1" 206 7540 "-" "-" 10.10.10.100 - - [25/Mar/2020:20:27:50 -0600] "GET /na/patches/wot_1.7.1.1844_na/wot_1.7.1.20228_1.7.1.20220_client.wgpkg HTTP/1.1" 206 16777216 "-" "wdsa::Torrents/libtorrent 1.1.9.0"
  18. Not sure how that is the case, I had it working fine with PiHole, just couldn't tell if it was actually caching properly or not. Here is how I have mine setup: 1) DHCP hands out DNS IP1 as PiHole IP and DNS IP2 as a dead IP. You have to do this because Windows will randomly ask DNS. It's not a "primary" and "secondary" IP, it's whatever Windows wants to use. 2) PiHole upsteam DNS is lancache-bundle server IP 3) lancache-bundle upstream DNS server is OpenDNS server IP This provides ad blocking (as well as blacklists), caching, and whatever filter settings yo
  19. Josh.5, I may be late to the conversation, but I am seeing the same issue as others with the logging. It appears the lancache-bundle access.log file is truncated. It is missing the "HIT" and "MISS" part of the logs as shown below in green. I googled this issue prior to coming here and noticed a lancache dev telling another person they won't support this docker because there is something wrong with it. lancache-bundle example (borrowed from another post): 10.0.0.4 - - [28/Feb/2020:22:33:18 +0100] "GET /depot/239145/chunk/afd533bb3c7a6f892dbff6232afa4b91d6f78704 HTTP/1.1" 200
  20. I can't wait to see what the new version brings. I have learned through DD-WRT and BWMON that it appears the downloading machine is bypassing the cache server during the download. I haven't dove in enough to know if it's somehow getting the real IP during DNS resolution or if it's the cache server leaking the real IP. My work around is to throttle the download speed for the first machine to 10Kbps. This forces every update packet to go through the cache server except for 10Kbps, which doesn't add up to much. Using this method, I am able to force the cache server to cache 90%+ o
  21. Not sure if it's applicable, but I've seen mine do up to 25MB/s download for an Overwatch update on the third computer from a mechanical drive. I have noticed that one machine will "miss" them all (of course, initial download), the second machine will "miss" every 3rd or 4th GET, and the third machine will only "miss" a few and get really good speeds. One thing I learned for sure, is that windows doesn't use the first DNS all the time, and "fall back" to the second DNS if the first isn't available, it will randomly pick them. So, if you have anything else listed as a second or third DNS ser
  22. First, I want to say thank you so much for putting this docker together. I have a super crappy internet connection and with three computers used to play Steam and Blizzard games, being able to update one machine (usually over night) and then updating the rest within minutes is so nice... With that said, I believe I found a potential bug that I "hacked" to get working, but if you could include an option in the configuration settings to enter the dnssec-validation option in the /etc/bind/named.conf.options file that would be awesome. The reason I ask, is I would like to be able to
  23. Additional detail, as I added an IDE drive from my old data server and it didn't boot. Apparently the BIOS decided to reorder what was listed under "Hard Disk Drives" and the USB device was no longer priority. So, I wrote down the exact names. Here's what to do: After going into the BIOS, select "Boot" from the top of the screen. Next, select "Hard Disk Drives" and highlight the USB Device and press the + key till it is at the top. Next, press ESC to go back to the "Boot" screen and select "Boot Device Priority". Again, highlight the USB Device and press the + key till i
  24. You might get better suggestions, and I'm hoping to read them as well, but I personally would use a cross-over cable and directly connect the two machines using static IP addresses. Then, from the new server, mount the shares of the old server then just do a 'cp -R *' from each disk to the new server. A quick dirty example would be: on the new server: # mkdir /mnt/olddisk1 # mount -t cifs //oldserverIP/disk1 /mnt/olddisk1 Now, if you 'cd /mnt/olddisk1' and do a 'ls' you should see all the files on the old server. # cp -R /mnt/olddisk1/* /mnt/disk1 Rinse and repeat
  25. Just built a system using an Asus M2N68-AM Socket AM2+ Motherboard, AMD Athlon 64 X2 processor, 1GB of Kingston KHX8500D1/1G and 3 Western Digital WD10EACS 1TB drives. Everything appears to be working fine. Only small note is the Bios configuration to boot to the USB device. You have to go into the Hard Drive Device settings and set the USB Drive to be at the top of the boot order for the drives. Then, go into the boot order screen and tell it to boot to the USB drive over CD-ROM and Floppy. If you don't put the USB Drive at the top of the HD list, it won't be available on the boo