Jump to content

b0rgi85

Members
  • Posts

    12
  • Joined

  • Last visited

b0rgi85's Achievements

Noob

Noob (1/14)

1

Reputation

  1. Also ich habe im Forum nachgeschaut und auch deinen Post mir angeschaut. Aber ich komme da trotzdem nicht wirklich weiter. Kriege immer noch die gleichen Fehler und in Nextcloud kann ich es nicht hinzufügen. Sagt immer der Server ist nicht verfügbar. Nehme an, es liegt am Config-File in NGINX von Swag ## Version 2021/05/18 # make sure that your dns has a cname set for code-server server { listen 443 ssl; listen [::]:443 ssl; server_name collabora.* "~^[0-9]{1,10}\.code-server\..*$"; include /config/nginx/ssl.conf; client_max_body_size 0; # enable for ldap auth, fill in ldap details in ldap.conf #include /config/nginx/ldap.conf; # enable for Authelia #include /config/nginx/authelia-server.conf; location / { # enable the next two lines for http auth #auth_basic "Restricted"; #auth_basic_user_file /config/nginx/.htpasswd; # enable the next two lines for ldap auth #auth_request /auth; #error_page 401 =200 /ldaplogin; # enable for Authelia #include /config/nginx/authelia-location.conf; include /config/nginx/proxy.conf; include /config/nginx/resolver.conf; set $upstream_app Collabora; set $upstream_port 8443; set $upstream_proto http; proxy_pass $upstream_proto://$upstream_app:$upstream_port; # static files location ^~ /loleaflet { proxy_pass $forward_scheme://$server:$port; proxy_set_header Host $http_host; } # WOPI discovery URL location ^~ /hosting/discovery { proxy_pass $forward_scheme://$server:$port; proxy_set_header Host $http_host; } # main websocket location ~ ^/lool/(.*)/ws$ { proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; proxy_http_version 1.1; proxy_pass $forward_scheme://$server:$port; proxy_set_header Host $http_host; proxy_read_timeout 36000s; } # download, presentation and image upload location ~ ^/lool { proxy_pass $forward_scheme://$server:$port; proxy_set_header Host $http_host; } # Admin Console websocket location ^~ /lool/adminws { proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; proxy_http_version 1.1; proxy_pass $forward_scheme://$server:$port; proxy_set_header Host $http_host; proxy_read_timeout 36000s; } } }
  2. Hallo Zusammen, ich nutze nun schon seit einiger Zeit Nextcloud und Collabora. Habe dazu damals die Anleitung von SpaceInvaderOne genutzt. Das hat bisher auch recht gut funktioniert. Nur leider ist seit einem Update nun die Funktion nicht mehr gegeben. Ich habe von LetsEncrypt Container auf Swag umgestellt und habe die Nextcloud gestern auf 23.0.3 geupdatet. Für den Collabora Docker Container gab es wohl auch ein Update. Jetzt funktioniert nur irgendwie nix mehr. In Nextcloud kriege ich angezeigt, dass der Server nicht verfügbar ist: Den Container von Collabora habe ich bereits nach einer Anleitung hier im Forum angepasst und der startet nun auch wieder: Alias Group 1: https://subdomain.domain.de:443 Mein Proxy-Conf File in Swag/NGINX sieht wie folgt aus: ## Version 2021/05/18 # make sure that your dns has a cname set for collabora and that your collabora container is named collabora server { listen 443 ssl; listen [::]:443 ssl; server_name collabora.*; include /config/nginx/ssl.conf; client_max_body_size 0; # enable for ldap auth, fill in ldap details in ldap.conf #include /config/nginx/ldap.conf; # enable for Authelia #include /config/nginx/authelia-server.conf; location / { # enable the next two lines for http auth #auth_basic "Restricted"; #auth_basic_user_file /config/nginx/.htpasswd; # enable the next two lines for ldap auth #auth_request /auth; #error_page 401 =200 /ldaplogin; # enable for Authelia #include /config/nginx/authelia-location.conf; include /config/nginx/proxy.conf; include /config/nginx/resolver.conf; set $upstream_app Collabora; set $upstream_port 9980; set $upstream_proto https; proxy_pass $upstream_proto://$upstream_app:$upstream_port; } } Ich erreiche so zwar die WebGui über UnRaid aber Nextcloud kriegt keinen Connect hin. Wenn ich mich lokal über UnRaid verbinde bekomme ich auch folgende Log-Einträge im Collabora Container: wsd-00001-00035 2022-04-21 07:09:59.699683 +0000 [ websrv_poll ] ERR #27 Error while handling poll at 0 in websrv_poll: #27BIO error: 0, rc: -1: error:00000000:lib(0):func(0):reason(0):| net/Socket.cpp:467 wsd-00001-00035 2022-04-21 07:10:02.140967 +0000 [ websrv_poll ] WRN client - server version mismatch, disabling browser cache. Expected: 5e2e1b6| wsd/FileServer.cpp:510 wsd-00001-00035 2022-04-21 07:10:02.142462 +0000 [ websrv_poll ] ERR JWTAuth: verification failed; Expected: dDUkm-nUeVAQGvsNbXoEGDGIj3y3Tre5FxTol8E62CvN8wsmhfQiAbhui_eAOQ4lPQE0HIsKGJHkkE_eq7swhxkTiqrBDH23EaybQiUe7h5p5a8zY0IMp6j-BcHqgGjzMGKBHh1rJP_MQJCOVc1jhcTPaV79PV3WKvW35Ev9xSX8Sv3sHF308_xe8b3nfaFe9CyFb9FZJWth2hMzKRgwgHcQb_sBktfGxxhwBkbWTQpNVJzQq9tY6VolFJ1ZWa6fX28GVsIbbAjlmcmBg_QZjJ0oAhrL1LBt-DNjUmyK1HfSzrSKNj-v7Yip_mI06KRZG7ni-LzErpkIeh061orjig, Received: kVUFTABHu6tyikEaUuIU4D1gtbFoZkI2nJdnhxv7J226UtOMDbGencctSuhDYiMY4aI31jAVbHDE4mQT_kFlf3WRr1fjvkRyxEQSH0IUQPaKFIY4GBZWB_DGfg7QZVke1UKCC2_BMx6YsfBOHJP28i2fSnbOqhbTGKgAn-t5og4uy_Hgpw-9fPnwWTeIaBLR2Wv2wD4XpVZUvDqDukd5Vrx0i-Q9gbMlS7P0d0Qh1W9CQInrKBQUPje7PxSYMhpeKJVD1PjJXnnBvERyhKyyqKyeu3gcPVOhOpPW7c776fuDNaF7vcy9FOXLsRNthLkhlx3I7OwKEwm0EjT6AY8LJg| wsd/Auth.cpp:134 wsd-00001-00035 2022-04-21 07:10:02.248824 +0000 [ websrv_poll ] WRN client - server version mismatch, disabling browser cache. Expected: 5e2e1b6| wsd/FileServer.cpp:510 wsd-00001-00035 2022-04-21 07:10:02.140967 +0000 [ websrv_poll ] WRN client - server version mismatch, disabling browser cache. Expected: 5e2e1b6| wsd/FileServer.cpp:510 wsd-00001-00035 2022-04-21 07:10:02.142462 +0000 [ websrv_poll ] ERR JWTAuth: verification failed; Expected: dDUkm-nUeVAQGvsNbXoEGDGIj3y3Tre5FxTol8E62CvN8wsmhfQiAbhui_eAOQ4lPQE0HIsKGJHkkE_eq7swhxkTiqrBDH23EaybQiUe7h5p5a8zY0IMp6j-BcHqgGjzMGKBHh1rJP_MQJCOVc1jhcTPaV79PV3WKvW35Ev9xSX8Sv3sHF308_xe8b3nfaFe9CyFb9FZJWth2hMzKRgwgHcQb_sBktfGxxhwBkbWTQpNVJzQq9tY6VolFJ1ZWa6fX28GVsIbbAjlmcmBg_QZjJ0oAhrL1LBt-DNjUmyK1HfSzrSKNj-v7Yip_mI06KRZG7ni-LzErpkIeh061orjig, Received: kVUFTABHu6tyikEaUuIU4D1gtbFoZkI2nJdnhxv7J226UtOMDbGencctSuhDYiMY4aI31jAVbHDE4mQT_kFlf3WRr1fjvkRyxEQSH0IUQPaKFIY4GBZWB_DGfg7QZVke1UKCC2_BMx6YsfBOHJP28i2fSnbOqhbTGKgAn-t5og4uy_Hgpw-9fPnwWTeIaBLR2Wv2wD4XpVZUvDqDukd5Vrx0i-Q9gbMlS7P0d0Qh1W9CQInrKBQUPje7PxSYMhpeKJVD1PjJXnnBvERyhKyyqKyeu3gcPVOhOpPW7c776fuDNaF7vcy9FOXLsRNthLkhlx3I7OwKEwm0EjT6AY8LJg| wsd/Auth.cpp:134 wsd-00001-00035 2022-04-21 07:10:02.248824 +0000 [ websrv_poll ] WRN client - server version mismatch, disabling browser cache. Expected: 5e2e1b6| wsd/FileServer.cpp:510 Auch ich kann über die konfigurierte Subdomain mein Collabora Container nicht ansprechen. Hoffe ihr könnt mir hier weiterhelfen?
  3. Habe nun Swag und letsencrypt einmal vollständig gelöscht und noch einmal neu installiert. Jetzt funktioniert wieder alles.
  4. Hallo liebe Unraid-Community, ich hoffe ihr könnt mir mit meinem Problem und meinem Unraid Server helfen. Ich habe dank der Hilfe von SpaceinvaderOne damals meinen Unraid Server eingerichtet und auch die Letsencrypt ReverseProxy Geschichte eingerichtet. Nun habe ich gesehen, dass die ganze Geschichte ja nicht mehr up to date ist und ich wollte auf Swag migrieren. SpaceinvaderOne hat hierzu ja auch ein super Video eingestellt, nur leider ist mir dabei ein wenig was flöten gegangen, da ich auch von DuckDNS auf Cloudflare (auch mithilfe von SpaceinvaderOne) umgestellt habe. Ich erreiche jetzt meine Docker-Container einfach nicht mehr über die Subdomains. Zudem bekomme ich im Log von Swag den Fehler: nginx: [emerg] unknown "allow_local_ip" variable Ich kann diesen Parameter aber nicht auffinden. Ich hoffe mir kann jemand helfen, wo ich ansetzen kann, denn ich stehe irgendwie aktuell total auf den Schlauch. Hier mal die Links zu den Videos: Migration Letsencrypt -> Swag: Cloudflare: Wenn noch Infos gebraucht werden, schreibt mir gerne. Beste Grüße b0rgi
  5. I downgraded to 6.9.0 and the system is running longer then one day. But I get the restarts when I start to stream something through Plex. Is the problem related to the transcoding?
  6. I got a Intel based setup, too. No NVIDIA Card and just running Docker-Containers. The system is doing randomly reboots and wants to do a parity check after rebooting. When I cancel the parity check after a few minutes, the system reboots. Hope there will be help ASAP. Here are my logs: b0rgis-unraid-diagnostics-20210311-1458.zip
  7. I had the same failure on my system via upgrading through the web-gui. After installing the update manual through the CLI my system works fine with 17.0.1
  8. Hey, I solved it without any data loses. I installed PHPmyAdmin and have done a backup of my mariadb database. Then I've done a fresh install of MariaDB (deleting the old AppData, etc.) and then restored my backup with PHPmyAdmin. After that everythings works fine.
  9. Ok I figured out, that it wasn't the nextcloud update. There is something faulty with my mariaDB Database. Can someone help me please?
  10. Hello everyone, i got a problem with my nextcloud installation. After I updated my docker-container (maria-db and nextcloud) via the unraid gui (6.6.7) my nextcloud is not getting up. In the error log of the nginx folder from nextcloud i got the following error message: 2019/05/10 06:38:50 [error] 312#312: *216 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2006] MySQL server has gone away in /config/www/nextcloud/lib/private/DB/Connection.php:64 Stack trace: #0 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect() #1 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion() #2 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform() #3 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform() #4 /config/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransactionIsolation(2) #5 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\DB\Connection->__construct... PHP message: PHP Fatal error: Uncaught Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2006] MySQL server has gone away in /config/www/nextcloud/lib/private/DB/Connection.php:64 Stack trace: #0 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect() #1 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion() #2 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform() #3 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform() #4 /config/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransactionIsolation(2) #5 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doc Can someone help me?
  11. Hi Everyone, hope to get some help here. I tried to do an online update in the nextcloud container from version 15.0.0 to 15.0.1. I think that was a bad idea, because my nextcloud gets stucked and it shows the following page only: Hope someone can help me with that. Thx for your help!
  12. Hey, I got the same error and i solved it. Change to Advanced View in the Docker settings and then edit the Extra Parameters. This helped me. But I got another problem now. When I started the postfixadmin setup (http://myip:8080/setup.php) I got the following error: Can someone help me with that?
×
×
  • Create New...